I use a Lenovo P1 mobile. I was able to connect the mobile to the PC through the USB charging cable which came with the box. As soon as I connect the USB to the PC, a notification would show in my mobile "USB Setting(not exactly sure)". I used to click on the notification and I was able to change the setting from "Charge only" to "MTP (Media Transfer". Thus, I was able to add my file to the Mobiles(songs, lectures etc).

Recently, after updating my Phone to Android 6.0.1; I am unable to do so. I have tried searching for the USB settings manually, but to no avail.

I would appreciate if you would help me.


You need to turn on the developer options in your phone (settings) Then under developer options you can set the USB transfer options. They moved it under developer options.

Hope this helps :-)


| improve this answer | |

Go to "Settings" first and then tap on "About Phone", hit "Build Number" till you can see the "Developer options" and then you can turn on USB debugging and manage your files.

Here I read an article about it: http://wccftech.com/enable-developer-options-in-android-6-marshmallow/, you can find detailed answers here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.