0

I have tried to flash the custom ROM CM 13 to my Lenovo A6000 plus as described in the xda thread. My phone was running on Lollipop and was rooted. I had twrp in my phone. So I simply copied [ED300-CM13.0-UNOFFICIAL-wt86518.zip] and [open_gapps-arm-6.0-micro-,,,,,.zip] to my external sd card and tried to flash them using twrp. Installation of ED300-CM13.0-UNOFFICIAL-wt86518.zip was seemed succes but open_gapps-arm-6.0-micro-,,,,,.zip showed an error as zip file corrupted.

I assumed the installation of later was only to include the necessary Google apps. So I thought not to install them assuming that they weren't necessary. I simply reboot the phone. Now my phone is in an infinite bootloop. It just shows the Lenovo logo, stays for 2-3 minutes and again go back to boot.

I tried to enter into twrp but didn't succeed. I can access the bootloader. So I put the phone to bootloader and connected to my laptop. But when I type adb devices it doesn't detect the device.

Did I really brick my device? Is there a way to get back? I just want to flash any compatible ROM so that the phone stays up. Please don't tell me to get back to xda :(

1

I've read the thread you linked and inspected the TWRP package inside. It looks like flashing for this device is incredibly simple, similar to a Nexus - it just flashes and boots a recovery image from fastboot. Lenovo even included a handy command to reboot straight to recovery from fastboot, which not even Nexus devices have.

Since you've flashed TWRP successfully in the past, I assume proper drivers have been installed, and you still have the whole folder on your PC. So right now what you're gonna do is boot your phone to fastboot, connect it to PC, open a command prompt window on PC then execute...

fastboot oem reboot-recovery

...which should take you to recovery.

If an error pops up then you might need to manually point to the fastboot location (drag the fastboot.exe in tools/ to the command prompt window), so it becomes something like...

C:\TWRP\tools\fastboot.exe oem reboot-recovery

(your path will vary).

  • I managed to get into recovery by pressing vol UP + vol DOWN + Power and flashed another ROM which works fine now. Somehow the CM 13 didn't work for me. Anyway, I tried your method also, which works and I am accepting it as the answer. :) – Anonymous Platypus Oct 12 '16 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.