-1

The challenge: I am not connecting to the new local mobile network for data after changing SIM cards.

Details:

- Handset: Samsung Galaxy S6

- Original service provider: Verizon - USA

- New/current service provider: Econet - Zimbabwe

I recently moved from the US to Zim, and brought my S6 handset with me. Verizon informed that all the phones come unlocked and that I could simple swap out the SIM card to the local provider. I have purchased a new SIM card and loaded up the necessary money onto my new provider account. I am able to send & receive SMS text messages and phone calls, but unable to get any data service, so applications like Google and WhatsApp do not work (unless I'm on WiFi).

Wondering if there is some setting in android or verizon which is blocking the data connection from the new network. I have double checked to make sure airplane mode is off, and in Settings > Mobile Networks > Network Operators I see "ECONET" and there is sufficient signal strength.

I appreciate the help. Thank you.

Matt

  • Contact your provider, and see if they require a setup procedure. – Dan Brown Oct 12 '16 at 20:14
0

For using Data Services You have to set APN first.

Goto Settings > Mobile Networks > Access Point Names Tap More and select New APN and use the following Settings:

Name: ZW - Econet Web

APN: econet.net

Proxy:

Port:

Username:

Password:

Server:

MMSC:

MMS Proxy:

MMS Port:

MMS Protocol: WAP 2.0

MCC:

MNC:

Authentication Type: PAP

APN Type: default, supl

Save the APN and use that APN. After doing all this reboot your phone and it should work like charm then.

  • Yes, this is perfect. I had not added the new network. Thank you, Rahul. – user191837 Oct 14 '16 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.