9

I already use the Android Gmail app. I installed Google Inbox and was receiving double notifications. Inbox offered to stop receiving Gmail app notifications. I agreed to this.

Then, I no longer wanted Google Inbox so I uninstalled it. Gmail notifications did not turn back on. I checked settings, apps, Gmail, notifications checkbox (yes), but still no Gmail notifications.

2

Settings - Accounts - select Google - make sure sync for Gmail is turned on.

2

So all of the above options definitely work. However, this is the only thing that worked for me.

Go to Settings > Apps > click the top-right corner and select "Special access" > Optimize battery usage > then where it says "Optimized apps", click that and select "All apps". Scroll down until you find Gmail and make sure it is turned OFF.

As soon as I shut mine off, I instantly received at least 20 emails on both of my Gmail accounts. Hope this helps somebody.

1

Go to settings > account@gmail.com > Notificatons > select All

0

For android 7.0

  1. Go to "Settings" icon in the top right corner.

  2. Select "Notifications".

  3. Click on the Gmail icon.

  4. Click on the Info icon (looks like i).

  5. Click on your account (most likely your email address).

  6. Click on "Notifications" and select "All"

protected by Community Mar 11 at 17:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.