So, yeah. I told a friend I would root his phone for him... and I went and soft-bricked it. Haven't told him yet, because I'm hoping I can fix it before long, but I'm running out of options (and time).

Side note:

I followed this guide when trying to root: www.reddit.com/r/MotoG/comments/22mimr/the_guide_to_rooting_the_motog_with_a_howto/

and got until unlocking the bootloader when I realized that instead of being a guide for the Moto G4, it was a guide for the Moto G on android 4.x.x.

So I did flash the wrong logo.bin, but hopefully that was the only issue created there. I got the correct one elsewhere and all was working fine.

End side note

So I moved to how-to-geek's tutorial here: http://www.howtogeek.com/115297/how-to-root-your-android-why-you-might-want-to/

I got twrp installed, booted in recovery and loaded SuperSU (version below)


Now it's softbricked. Kind of just hangs on the boot screen.

I can get into the bootloader and twrp, but that's about all I can do at the moment. I've tried reseting the cache and dalvik cache, and have tried formatting the device with no luck.

My next step is that I'm installing vanilla firmware from:


and I plan to try to flash that when It's all done. I'm unsure if that's safe, but don't have many other options.

If you know anything I can try, please reply. Any help is greatly appreciated


3 Answers 3


Proper research would have prevented this, in the future if you need information on rooting a device, go to a REPUTABLE source like XDA or a similar forum and make sure the information is specific to your device AND the current Android version. Lollipop, Marshmallow, and now Nougat are changing the way rooting is being done.

All retail/unlocked Moto devices running Marshmallow have an extra step that is required when flashing to force a systemless root installation by the SuperSU install script.

After successfully flashing TWRP and booting it, go to Advanced - Terminal and enter:

echo SYSTEMLESS=true>>/data/.supersu 

And press Enter, then exit. The spelling and spacing must be exact or it won't work. Then go to the main menu of TWRP and flash SuperSU normally, you should see the script specifically state it is doing a systemless install and patch the boot image (and in your case, cleanup an old standard root installation).

Please use only the referenced version from my thread (yes, I am the original author of that source thread), they are tested and working to both root the device, and cleanup a failed root.

Be aware on the first boot after this procedure, the device will boot loop twice, do not be concerned, this is normal, then it will boot normally after that.

And since you did not do a nandroid backup before rooting (shakes head), you may need to flash back to stock via fastboot before this procedure will work. The image for your device is available here. Remember that you cannot flash this in TWRP, you MUST flash each partition manually with fastboot and this will return the device to out of the box condition.

  • @beeshyams Yes, you can go to mounts in TWRP and change the system write option there. This should not affect backups though, only restoring them.
    – acejavelin
    Commented Oct 14, 2016 at 2:42
  • @beeshyams I saw that... the tick box was the issue, I was trying to say that but I guess I wasn't obvious. Glad you got it working!
    – acejavelin
    Commented Oct 14, 2016 at 13:22
  • Thank you so much! Really a lifesaver. You are right, I probably should have done better research before starting. This is the first time I've rooted anything, so I didn't know what was reputable or not. I figured how-to-geek was fairly reputable, but I guess I was wrong. Again, thank you so much
    – Yonah Karp
    Commented Oct 14, 2016 at 13:48

Exactly the same thing happened to me, didn't backup and everything just like you. I realized that the rooting SYSTEM LESS root guide I was following did not work for Android 7. I was following this guide here that did not specified to make sure you are in Android 6 before rooting. Everything worked except the rooting part where I got soft bricked. Link to Install TWRP in Moto G4

If you managed to install TWRP you can follow this guide here XDA Moto G4 I was able to unbrick my phone, moto g4 XT1625


Be aware: The Amazon lockscreen ads & bloatware on the Moto G4 (XT1625) can NOT be removed. Nor can the phone be rooted.

It is possible to unlock the bootloader, and TWRP can be loaded, either in RAM (temporarily) or flash (non-volatile). But the additional SuperSU.zip root package can NOT be loaded, doing so will soft-brick the phone.

After the soft-brick, I was able to reload a Motorola XT1625 factory image on it, after which all the Amazon stuff and associated lockscreen ads are actually gone. However, the phone will then keep pestering you about downloading the latest "system update". When you agree to that, all the Amazon stuff will be back (while still being the same Marshmallow V6.01 version as before the update). When you don't agree to the system upgrade, it will pester you for the update from here to eternity, which is actually even worse torture than the lockscreen ads. To top it all off: The update message nag can NOT be removed.

So my end conclusion about this phone, after having worked on this for several days with just about every method tried as described on the internet, is that this phone can NOT be de-Amazoned. At least not with the methods as they are known today. The problem seems to be in the update software channel which is set for “AMZ”. This causes system updates forced on the phone to be of the Amazon kind. The only way to fix that is to get the software channel setting set for a generic code. However, there is no working method available on the internet today to accomplish that, believe me.

So to summarize: Spend the extra $50 and get the generic G4 model without the advertising crap. That is what I have done now; I have returned it and successively bought the ad-free version for $50 more. Because that is the good news: The Moto G4 X1625 is a VERY good phone, it is worth the extra $50.

  • This isn't really an answer, and your information is incorrect, at least partially... Flagging as not an answer.
    – acejavelin
    Commented Jan 2, 2017 at 16:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .