15

I'd like to use the MyPhoneExplorer application to sync my Android smartphone with Windows over USB. This requires first installing a driver for the phone and the ADB application.

However, the official driver seems only available as part of the Huawei HiSuite bloatware: http://consumer.huawei.com/minisite/HiSuite_en/index.html

Can someone confirm that there's simply no official driver from Huawei, and the alternative is either installing that bloatware, or find a non-official (possibly virus-carrying) driver somewhere?

Thank you.

11 Answers 11

7

Ex Honor 6 user

Confirmed. There is no other way except installing Hi Suite or risking unknown driver. Tried unsuccessfully with several trusted universal drivers

This is my conclusion after I searched in several forums like XDA, Huawei forums ( trawling is a problem as they are in Chinese and one had to depend on Google translate) and Facebook sites of Huawei users. My search was motivated by unconfirmed posts that HiSuite send user information to its servers- bloatware I could live with. I was left with no option but install HiSuite

| improve this answer | |
  • Thanks much. I'll just install HiSuite, then, rather than installing some unofficial driver. – Gulbahar Oct 16 '16 at 5:54
20

Drivers are not distributed as standalone package in order to increase market penetration of the HiSuite software. It's quite popular marketing strategy: you can get what you want only in bundle with something you don't actually want, but need to get the primary item is big enough to make you buckle in and get the whole package.

Nevertheless, you can circumvent the bundling yourself:

  • download the HiSuite installer.
  • open the installer .exe with 7zip and extract its content preserving internal folder structure (a trick that works on most installers)
  • find something that looks like the driver
  • run/install it, preferably on a disposable system first, to prove it's what you want.

In HiSuite version 5.0.1.300 it was \$_OUTDIR\Driver\all\DriverSetup.exe. Works with P8 Lite and Mate 7.

| improve this answer | |
  • 2
    This is very good, saved the trouble of installing extra software. I already have HiSuite on another computer (just for storing backups and the like). – Karim O. Aug 16 '17 at 4:08
4

I was looking for those lately, sorry for Golden Shovel award, but if I found this thread then maybe someone else will find this helpful.

Download installer for this HiSuite. Unpack it, like archive (I use 7-zip). It asks for file replace, just 'yes' it (it is because installer format, don't worry). If you order your Windows to look for driver inside this unpacked folder it will find it, but from catalog tree you should know what's what.

Bang, you have driver without installing crapware.

| improve this answer | |
  • 1
    duplicate answer – PythoNic Oct 19 '18 at 19:07
4

If you just want to directly access your Honor (I've got an Honor 6A) phone, go to "Settings", "About Phone", press 7x "Build Number" - the phone tells you, that "You're now a developer!".

Go to the new "Developer Options", activate "USB Configuration" an choose MTP or PTP. After that I could access the internal phone memory and the SD card directly via Explorer in Windows - without installing HiSuite or any Drivers or something special. Without these steps I only got a HiSuite Installer Option and no access to the phone's memory.

| improve this answer | |
  • Thanks! "Developer options" are near the same menu as "About phone". – CoolMind Dec 14 '19 at 20:07
1

You can install manually the Google USB driver that comes with the SDK for Android developing, it works to use adb on several Android phones, when you're in the process to install it, Windows might tell that the driver might not work properly, but it doesn't care.

| improve this answer | |
1

As @Gulbahar said, there is no way except installing the HiSuite or relying on unofficial drivers.

What I did and worked was installing HiSuite, restart my pc, and without connecting my phone to HiSuite for privacy concern, uninstalled HiSuite software. Happily when I uninstalled HiSuite it did not uninstalled the driver :).

| improve this answer | |
1

Perhaps it is because my phone is brand new (Nova) but when plugged into windows 10 it asks if for charging or file transfer. If you chose the latter you can access the phone and memory card.

| improve this answer | |
0

Here is the official way to install the driver. It is suggested to connect the phone as a virtual USB-device and install drivers from it. Worked fine for me.

| improve this answer | |
0

Actually there is a solution, so follow guide below:

Step One

1.download "HiSuite" from this link: https://consumer.huawei.com/minisite/HiSuite_en/

2.extract the compressed file then extract "Hisuite_8.0.1.302_OVE.exe" file using 7-zip.

Step Two

To install the Android USB driver on Windows 10 for the first time, do the following:

1.Connect your Android device to your computer's USB port.

2.From Windows Explorer, open Computer Management.

3.In the Computer Management left pane, select Device Manager.

4.In the Device Manager right pane, locate and expand Portable Devices or Other Devices, depending on which one you see.

5.Right-click the name of the device you connected, and then select Update Driver Software.

6.In the Hardware Update wizard, select Browse my computer for driver software and click Next.

7.Click Browse and then locate the folder you just extracted from ".exe" file

8.Click Next to install the driver.

Good luck.

| improve this answer | |
0

Not really an answer to the above question but I found this question when trying to find ways to transfer files without needing HiSuite. I wanted to comment on an existing, related answer but in some step of brilliance on the part of I fail to understand you need less reputation to answer than to comment.

If you just want to access the files go to Settings -> About Phone and tap on the Build No. 7 times. You should get a message (a toast) informing you you're now a developer. Search for enabling developer mode on your phone specifically if you're lost. As Peter said in his answer you can select the file transfer protocol but in my case I also had to enable USB Debugging for the internal storage to show up in my file manager. Why this isn't default behaviour escapes me.

Hope this helps someone because it stole 40 minutes of my life.

| improve this answer | |
0

The trick is to make android OS connect you before Hisuite bloatware kicks in.

Go to settings > developer options > under select USB configuration > select MTP. then connect your USB.

When you unplug the USB, Huawei will reset it back to charging, hence forcing you again to use it. so you'll have to change the developer options configuration every time you need to connect your USB. This way worked for me on the EMUI 10.1.0.286

I have a mate 20 pro that have been driving me crazy since the EMUI 10 update. Hisuite is ONE of the issues where Hisuite is forced on us now instead of a regular file transfer. Since I was previously able to connect my phone using USB and use it as storage, or backup, etc. Not anymore.

I did have no choice but to install it and give them a copy of my life, i will email the privacy department and request that they delete my details. That's what their website says to do!!!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.