1

A can of worms were opened all because I was logged out of Snapchat. I got new a phone about a month ago called the Samsung Galaxy A9 Pro. It was only sold in China and Hong Kong. When I got it it worked like anyone other Android phone, but it came with root already on it with some program called Team Win Resource Project. After discovering it had root, I got some rooted apps for it. Then, a friend wanted to log on Snapchat so he logged me out but he couldn't log on. I tried to log on and it still wouldn't work. Eventually I discovered I couldn't log on because I modified the root folder. So I tried to unroot it with SuperSU and that took me to the TWRP screen after I rebooted it. I didn't know how to get past that screen, but a video I watched showed me how to fix it (or so I thought) by installing the original firmware. After doing so, I didn't have any Google services and the play store was replaced by the Samsung store. I tried installing the Google Play store with the play services and play services framework, which only slowed down my phone ("unfortunately, play services/play services framework stopped working"). I uninstalled all play services and now I have absolutely no clue what to do or where to go to get Google Play back. Please help me.

  • TWRP is there because A9 Pro isn't supposed to have Google Apps preinstalled, therefore the previous owner installed it so that he could install Google Apps through it. You will either need root or TWRP to install GAPPS properly - just installing it within the OS won't work. Also, how come Snapchat would not work just because the device is rooted? – Andy Yan Oct 19 '16 at 0:10
0

Try google play installer apk. It will hep android phones to install gapps.

  • 1
    What "Google play installer" are you talking of? Could you provide any link? I've never heard of such a tool. Usually, GApps are installed by flashing their archive – if they don't come pre-installed already, that is. – Izzy Oct 21 '16 at 13:32
0

1)For getting store again , you can simply restore your mobile phone, thats the one solution. 2)Download play store apk file from google store and install it.

  • 1) how to do that? and 2) Unlikely. As Andy already pointed out in his comment on the question itself, that won't work. It's a) a system app and b) needs to be flashed with the GApps package usually. – Izzy Oct 21 '16 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.