2

I'm on Android 5.0.1. Yesterday, I received several "Unfortunately, Google Play services has stopped working" notifications, which I ignored as I assumed whatever had crashed would restart.

But when I went into my Gmail app later, instead of seeing my inbox, I was asked to add a new account. Then, I checked Accounts in settings, and my two accounts were still there, but would not sync. When I try to remove the accounts, nothing happens (i.e., I press the "Remove account" button, and the phone simply does nothing).

I can connect to the internet consistently. However, it seems I am not receiving push notifications from any apps, including non-Google ones like Facebook messenger. And I cannot open other Google apps, e.g. Play Store (when I try to, I'm met with a blank white screen).

Any help solving this mess would be much obliged!

  • Have you restarted your device? – DukeSilversJazz Oct 19 '16 at 14:19
  • Yes, several times. No dice. – Sameer Kailasa Oct 19 '16 at 14:33
  • Tried to clear cache of "all things related" (note: cache, i.e. no data lost) – playstore app, gmail, play services, etc? Maybe even complitely ditch all cache (e.g. booting to recovery, selecting to "wipe cache")? – Izzy Oct 19 '16 at 14:54
  • Just ditched all cache, and still the problem persists. :( – Sameer Kailasa Oct 19 '16 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.