1

I recently bought the Archos 50 Power however I sent it back after it appeared to be faulty. Today the new one came, however, the exact same problem is occurring. I have an SD card that I used in my Samsung Galaxy 4 and it worked fine. I then formatted it and placed it inside my new phone. The phone can see the SD card.

enter image description here

When I go to try and move any data, such as google play music downloads or photos from the camera app, to the SD card the apps cannot see the SD card.

enter image description here

The interesting thing is when I placed my SD card back in my old phone, put my google play offline on the SD card, then replaced it inside my new phone the google play music app could see the SD card. All the other apps could still not see it. I would appreciate any help in fixing this problem as I have never encountered it before now.

3
  • You can try if app mentioned here helps. Had a somewhat similar problem and this helped
    – beeshyams
    Commented Oct 20, 2016 at 17:01
  • go to Settings > Apps > Show System Apps and find External Storage and Media Storage and clear data and cache on each one and reboot, then give it some time after full boot up to rebuild media databases Do the above after removing and reinserting SD card
    – beeshyams
    Commented Oct 20, 2016 at 17:04
  • @beeshyams Unfortunately that did not work. Thanks for suggestion though
    – Dan
    Commented Oct 20, 2016 at 17:16

0

You must log in to answer this question.

Browse other questions tagged .