1

following some threads on improving battery life, I want to disable touchboost on my Google Nexus 5.

I am on:

  • MultiROM TWRP
  • ElementalX N5 Kernel
  • Android 6.0.1, non CAF

And currently using the EX Kernel Manager to manage my CPU settings.

In this thread: https://www.reddit.com/r/AndroidQuestions/comments/43cq7h/ex_kernel_manager_no_touchboost/

It says to reflash SuperSU and select "Do not install" when TWRP asks to install SuperSU. The problem is, I can reflash SuperSU, but the "Do not install" option does not come up.

Do I need to completely remove SuperSU to get this option? Thanks.

0

1 Answer 1

1

I don't think it matters. If you install the the correct kernel you should be able to disable touchboast. See my screenshot below.

Remember if you're updating to a new stock ROM, you can skip flashing TWRP recovery as may be patched on first boot anyway. So you'll need to flash TWRP and SuperSU again after first boot. So after first boot, put your device back into bootloader mode, flash TWRP, reboot the boatloader, then you can boot into recovery and install SuperSU.

TWRP does not ask to root anymore from my recent experience. I've flashed a Nexus 5, 2 Nexus 5x, and a 6P recently with the most recent version of TWRP, factory ROM with the latest security patch (July) for 6.0.1.

Again, each time you typically update to a new version of the stock ROM, you need to flash TWRP, then transfer the most recent ZIP of SuperSU to your SD and install from TWRP (make sure you wipe your davik/cache!). Once you've done this, you can install EX Kernel and then modify your gov, cpu, and turn off touchboast.

I know you have a Nexus 5 but this post by SlimSnoopOS on XDA will show you everything you need to know on rooting, backups, TWRP, custom roms, kernels, etc. I'd also check out this post by soniCron, regarding the exact task you're trying to complete, which is modifying your gov on your CPU so your battery will last longer.

Hope this helps.

screenshot of Ex Kernel app showing touchboast disabled

screenshot of Ex Kernel app showing updated kernel

9
  • Hi, I have installed the ElementalX kernel as stated, and rooted. However, in EX kernel manager I can't see touchboost. Going through my /sys/module directories, I don't see an option to disable touchboost as well. Any thoughts? Should I reflash the ROM? Also, should I root before I install the EX kernel, or not?
    – negusp
    Commented Oct 21, 2016 at 11:02
  • you installed the app. you still need the kernel. open EX and tap ElementalX and install the custom kernel. once you do that, different options will appear within the app. I'm assuming you installed the app only. ElementalX won't work unless you're rooted
    – fady
    Commented Oct 21, 2016 at 18:24
  • I added a screenshot to my answer showing my phone has the updated kernel
    – fady
    Commented Oct 21, 2016 at 18:28
  • I installed the kernel- flashed it from TWRP. Unfortunately, I think I just bricked my phone (an actual hard brick). When I boot it gets stuck in a bootloop; when I try to enter the bootloader the stupid thing boots to the system within 2 seconds. I took the phone apart and checked out the power button, and it looks OK. Any suggestions or workarounds, like perhaps a hardware reset or a different button combo?
    – negusp
    Commented Oct 21, 2016 at 20:34
  • yes. download the factory image here: developers.google.com/android/nexus/images?hl=en also, check out step 10 in this post (forum.xda-developers.com/nexus-5x/general/…) which will show you the steps to make it stock again. if you can still boot into the bootloader and flash the device then you're not bricked.
    – fady
    Commented Oct 21, 2016 at 20:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .