1

I have a Oneplus two. I tried rooting it, and badly failed. The device boots up but doesn't go past logo screen. Which says "Powered by Android" along with Oneplus logo. I would be able to fix it myself by accessing the internal storage and factory resetting it. However, my computer doesn't recognise the device as plugged in. The device does charge when I plug it in however. I tried installing drivers and that didn't help. When I was trying to root it, I did have USB debugging enabled to transfer files but now it doesn't have an effect. My query is how do I fix this problem? I tried to take it to a repair shop and they said the LCD is broken? But my screen is fine? PLEASE help me, I don't want to have to buy another phone.

  • Is it in fastboot/recovery/whatever a Oneplus two has? – Dan Brown Oct 21 '16 at 20:00
1

When you plug it in to your computer, look for a USB device called QHUSB_BULK, Unknown Device, or Qualcomm Device. If you're running Windows, check under the device manager. If you're on Linux/Ubuntu, use this command while in the terminal:

lsusb

If you see it, you can install the Qualcomm drivers, and use the recovery tool to reflash stock recovery and OS. As long as none of the other partitions were corrupted, this should solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.