1

I have a Nexus 6P running CyanogenMod 13.0-20160819-SNAPSHOT-ZNH5YAO0IN-angler based on Android 6.0.1. I used to be running a CM nightly build and my cell carrier is Ting. Here's what happened:

I was running a CM nightly build from March-ish for a while. A couple days ago, I upgraded to the latest CM nightly. Immediately after that my WiFi stopped being able to find/connect to networks, and a day or so after the upgrade my cell network data connection stopped working. (SMS and phone calls worked, however.)

I decided to switch to a CyanogenMod snapshot release, so I factory reset the phone and flashed CM and gapps (at the same time). I wen through the setup and lo and behold, the problem appeared fixed. However, when I restored all my stuff via oandbackup (including, I now realize, some system apps), the problem reappeared.

Thinking that there was somehow some system app with corrupted data that I'd now restored, I used oandbackup again (along with a TWRP backup) and factory reset again. I went through the setup, planning to simply restore apps one by one until I found the culprit, but the freshly-setup install had the same problem. Therefore I restored the TWRP backup, which brings us to now.

So, why can't I connect to data? Most of the time this problem causes the cell indicator in the status bar to have a "!" however sometimes it shows just the bars, without a "!" or the "LTE" indicator. I believe this behavior occurs when the phone is first booted and goes away for the remainder of the boot when Airplane Mode is toggled, but I can't confirm for sure.

Here's what hasn't worked:

  • Wiping Dalvik cache
  • Trying most of the APNs, toggling Airplane Mode in-between
  • Restoring the default APN settings
  • Selecting a network operator (there used to be two or so "Ting" entries available; I only tried one - now nothing shows up at all)
  • Selecting "choose automatically" in the Network operators settings
  • Toggling the preferred network type to 3G and back to LTE (toggling to 3G caused everything but the status indicator bars [i.e. the "!" and "LTE"] to go to away; I suspect Ting simply doesn't have 3G available anymore)
  • Turning on Data Roaming and toggling Airplane Mode
  • Downloading a factory image from Google and running flash-all.sh (i.e. flashing stock recovery, system, radio, etc.)

ADB logs of me booting my phone to the launcher and waiting a couple seconds for it to connect to the cell network: https://gist.github.com/strugee/cd61dbcc461bb17216c360516e711d29

  • Probably a bad radio - nightlies are not stable versions, they have bugs. Did you read the release notes? – esQmo_ Oct 22 '16 at 21:05
  • @esQmo I didn't read the release notes but as I said in the question, I'm not on a nightly anymore. I'm on a snapshot. – strugee Oct 22 '16 at 22:28
  • Flashing the nightly may have damaged the radio, or at least may have changed the radio. Try to flah a stock firmware and see if the problem is solved. You should read the release notes to know what is broken or not – esQmo_ Oct 23 '16 at 5:47
  • @esQmo you mean the radio partition? or the physical radio? – strugee Oct 23 '16 at 7:03
  • The radio partition. I think the one you flashed with the nightly does not support your network or the 4G networks. A stock firmware could solve this. – esQmo_ Oct 23 '16 at 7:06
0

Turns out this wasn't a problem with the phone. I called Ting customer support and apparently all that happened was I hit 5 GB of data usage, so they shut off my data automatically to prevent an unexpectedly huge bill at the end of the billing cycle.

According to the support person, you can self-service this by logging into Ting and looking at your device settings - the "can use data" option should be off. Turn it on and you'll be good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.