1

My personal phone is a Moto G LTE 1st gen (XT1045 - peregrine). At some point it stopped receiving network signal, so I re-installed Android 5.1 using a zip from XDA. I also rooted the phone.

Now my system version is 23.21.37.peregrine_retus.abc.xyz, whatever. I got a notification that I can install a new version, and I accidentally downloaded it. The problem is that I don't want to install it, but I keep getting reminders and I always postone. Where can I find the downloaded file to delete it? I didn't find anything in \cache in the internal storage. I looked in a lot of places using ES File Explorer, but I couldn't find the file that would be used for the update.

  • I rooted my phone using the SuperSU from TWRP. – Sorin Adrian Carbunaru Oct 24 '16 at 7:05
  • Thanks for the tip. I used the file manager of TWRP, but in \cache I only have a zip file with my current system version (Blur_Version.23.21.37.peregrine_retus.retus.en.US.zip). I expected to find a zip file with the version to update to (which has a 61 somewhere in the version number). – Sorin Adrian Carbunaru Oct 24 '16 at 8:27
  • possible that the update is a minor update and the number is the same? You can delete that and check if reminders vanish. Further, of this is the first update after using the phone, it confirms this possibility. If the reminders vanish, your problem is solved – beeshyams Oct 24 '16 at 8:35
  • 1
    I renamed it. Thank you for your help. Suggesting to use TWRP's file manager was very helpful. I hope I will remind to come back and let you know if this solved the problem. – Sorin Adrian Carbunaru Oct 24 '16 at 8:45
  • 1
    I dind't get the download message until now. I used to get it quite often. Probably the issue is fixed... – Sorin Adrian Carbunaru Oct 26 '16 at 8:54
0

Location is /cache usually, but for explorers even with root enabled cannot browse certain locations (not sure if you are using systemless root, in which case ES doesn't get root permissions )

Booting into recovery and using TWRP file manager (Advanced tab) allows you to browse and delete the update file as confirmed by OP

Regarding the other problem of update installation messages popping up, one way is to identify and "freeze* those /system components responsible for searching updates. You would need to search for indicative names. On my device (Moto X Play), freezin configupdater,SEpolicy update,Motorola update services did the trick. I use ROM Toolbox to freeze . Other alternatives like Titanium Backup should also work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.