1

Received a 128gb Samsung Evo+ microSD card that had originally been encrypted or used as adopted storage on another android device.

Current partitions, gpt table

/dev/mmcblk0p1 android_meta 16.00 MiB; /dev/mmcblk0p2 android_expand 119.74 GiB

I tried formatting it through android with no success, so moved to a pc with a card reader. Windows detects the partitions but formatting and re-partitioning is unsuccessful. Diskpart ends in successful readout, but after ejecting and reinserting the disk no changes have taken effect.

Under lubuntu, using gparted, usually results in a

i/o error during write on /dev/mmcblk0

and

error fsyncing/closing /dev/mmcblk0: i/o

Fdisk shows successful readout, but still not operational. Wrote 0's to the disk using dd and then tried again in gparted and same errors.

Any other ideas? Is the SD card shot?

  • If you wrote 0's to the device with dd and still can't write a partition table and format successfully, the card is bad. Contact Samsung customer service, I believe those have a lifetime warranty. – acejavelin Oct 23 '16 at 23:52
0

run the diskpart command from an elevated windows command prompt. type "list disk" type "select disk #" (get number from list disk command) type clean

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.