My daughter was using this Nexus 5 device and the power button started causing her problems. Well I removed the power button and ordered a new one. So now the power button is not an issue. But I guess during the time that the phone constantly kept rebooting due to the bad power button, something got corrupt. Now the device gets to the boot animation and never goes any further. There are no options in recovery for me to use. I have working ADB and Fastboot on my PC. I can see the device with Fastboot but not ADB because I can't get the device to boot into the OS for me to enable USB debug. But I know ADB works because I used it just the other day on a Galaxy S5.

I have tried to run fastboot oem unlock, it unlocks the device then once you reboot the boot loader, it says locked again. I have tried using Nexus Root Toolkit and hit unlock and it unlocks then says the phone will reset itself and just be patient. It may appear to bootloop but just wait. I waited for an hour and still just sits at the boot animation.

What are my options without being able to enable USB debug since the device will not boot to the OS?

I am able to Temporarily boot to a custom recovery, but I can't mount data!!! With Temporary TWRP, I am able to use ADB and I get a success message when I push a new system image to it, and when I push twrp recovery to it, but when the phone reboots, I find out that neither the system image or recovery were actually installed.

I looked into bad partitions, tried some fixes, and nothing works. I am so far beyond frustrated with this thing. I guess I will wait one more day to see if anyone else has any other ideas for me to try, then I am just going to put it in the trash.

  • Bootloop
  • Bootloader doesn't stay unlocked
  • Unable to mount storage
  • USB Debugging is not enabled and can't be enabled
  • Can't install OS image
  • Can't install Recovery
  • Can run TWRP temporary
  • Can use ADB when TWRP Temporary is running, still can't mount anything
  • Welcome! FYI, Its a boot-loop. Same thing though.
    – Dan Brown
    Commented Oct 23, 2016 at 22:45
  • Hmmmmm, sounds like a soft-brick. Can Nexus root toolkit flash the Stock ROM? If so, do that; you will lose all personal data
    – Dan Brown
    Commented Oct 24, 2016 at 9:14
  • No it won't work. I tried that several times and still gets stuck in boot-loop. When I try to format and erase in Temporary TWRP, it says unable to mount storage.
    – xRuhRohx
    Commented Oct 24, 2016 at 11:42
  • Did you use the mount option in TWRP to mount it manually? Does help ;)
    – Dan Brown
    Commented Oct 24, 2016 at 12:11
  • Yeah, it won't let me mount /data. I tap on it and it thinks about it, but never mounts it. it lets me mount /system and /cache.
    – xRuhRohx
    Commented Oct 24, 2016 at 12:32


You must log in to answer this question.

Browse other questions tagged .