1

I own an old Motorola XT910 that has several malwares, so I'm trying to delete them from the /system/app folder (since they're set as system apps), but when I try to mount the system as read-write, via adb shell I get Invalid argument. I've tried many commands but no success. Anyone knows how this can be done? What I've tried:

adb shell
su
mount -o remount , rw /system
mount rw, remount rw /system
mount -o rw,remount /system

The phone runs Android 4.1.2, rooted, BusyBox installed

  • You may like to try Root Essentials . It does it for me well ( I am not comfortable with adb , so prefer an app). It is by one of our site regulars – beeshyams Oct 24 '16 at 19:12
  • But I've also tried with Terminal Emulator, the system just refuses to mount! – esQmo_ Oct 24 '16 at 19:14
  • You have root on the device? So when you type in "su" in the Terminal Emulator, it asked to grant root permissions and changed the $ to a #? – DukeSilversJazz Oct 24 '16 at 19:19
  • Permissions granted, $ > # – esQmo_ Oct 24 '16 at 19:20
  • @beeshyams Not exactly the same problem... – esQmo_ Oct 24 '16 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.