1

I have a phone Samsung GT-S5302 it has stock ROM and root.


When it connects to internet it started to sync as always (sync icon appears), but the icon doesn't disappear even after 8 hours and I can't enter Google Play Store, Google+ account, Hangouts, I get an error "Google Talk authentication problem" and it reduces all phone performance.

Then I try to freeze Google Play Services with Link2SD problem disappear: sync works fine, error disappear, I can enter to Android Play Market, download and install app... But in this case Google+, Hangouts of course don't work because they need Google Play Services to work fine.

What I've already tried:

  • I tried to erase cash, app data of the next processes: Play Market, Google Play Services, Google Services Framework and reboot device.

  • I tried to erase userdata and add only my google account again with no changes.

  • I tried to reinstall gapps for gingerbread using CWM unsuccessfully again.

  • I tried to switch off automatic date/time settings and after reboot turn on again - no luck.

  • I tried to delete Google Play Services and reinstall it with Play Market - the same problem.


So the question is: Is there any way to solve the problem with Google+ or may be one know where do I need to look or what do I need to do further?

  • Have you tried restoring factory settings? Is the problem new? – DrA7 Oct 25 '16 at 19:47
  • After restoring factory settings, adding Google account and launch Google Play Market I get the same problem: Google play market download Google Play services and it try to sync something. So as I understand it is not because of my installed applications (they are absent) or root privileges (I removed root but it doesn't help). I start to think nowadays that it is because of mobile hardware that can't work properly with new versions of Google Play Services. – Alexander Oct 28 '16 at 16:38
  • Maybe if you look at the log it might lead you somewhere. Good luck. – DrA7 Oct 30 '16 at 21:32
0

After looking through verbose log of my mobile phone I noticed that Google Play Services (GMS) can't find class "android.os.UserManager" and it has another dead codes connected with Google Play Services (gms).

enter image description here

And this blocks of errors apear over and over again so Google Play Services restarts them self. Class "android.os.UserManager" require API level 17; my phone has API level 10 so I decided to install the older versions of Goolge Play Services. After that I find out that problems appear with versions of Goolge Play Services greater then 8.3.0. With 8.3.0 and below there is no such problem. Google+ works fine with this version of GMS.

I install all programs that I need using Play Market and after that I delete all data and updates of Play Market to prevent updating Goolge Play Services (I find out that Play Market respones for updating Goolge Play Services).

-1

I too had this problem. I think you too have noticed that the Google Play Services app crashes as well. So I firstly uninstalled it.

Then after rooting my phone, I factory-resetted everything (lot o f times) and after that, now it works smoothly. And no problem in synchronization either.

  • Welcome to Android Enthusiasts! Please don't use "txtspeak" / "SMS lingo" on SE sites, but rather fully spell each word. Many users here are no native English speakers, and some already have a hard enough time to follow normal English. – Izzy Nov 11 '16 at 13:12
  • I don't think suggested variant might help me. Because I tried even to format data, system, cache partitions using CWM and after that I flash stock ROM using Odin. And this doesn,t help. – Alexander Nov 14 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.