I am running out of Ideas how to get MTP working again... I am simply not getting the dialog again on my android, asking me wether I want just charging, or MTP or Picture mode...

Until most recently, it was easy: Use a USB cable, concect it to my Ubuntu 16.04 Laptop, get the mentioned choice/approval box... and voilà the Tablet appeared as an MTP device in the Ubuntu ‚file explorer‘ (caja) nicely auto-mounted.

  • got an Samsung Galaxy S2 tablet
  • running Android 6.01
  • it worked until recently in this configuration

I already followed some advice:

  • I made the developer options visible (by tapping the about device info thrice)
  • enabled USB debugging (which some sources say, is something to watch out for)
  • dialed on the phone menu *#0808# → which shows I'am on (o)AP and on MTP + ADB mode just like I should (this radio box btw only holds its state, if USB debugging is enabled)

also...

  • tried different USB ports
  • tried different cables
  • tried with another device (MacBook. Thus I have no reason to believe, I messed something up on the host machine OS side... Ubuntu is very stable anyway)
  • External Store (4kb) under Settings→Applications→“Show System Apps” is on

well, one last clue:

  • Settings → Tethering has the USB switch grayed out „USB cable not connected“. Althoug it clearly is. And I can recharge my tablet through it (otherwise I would have certainly noted...)

Device is not rooted. No other glitches. Are there maybe some log files (now that Dev mode is enabled) to check out what might got wrong?

Not looked/understood ADB yet. So I couldn't tell you, if that works. Anyway, no dialog to choose upon connecting.

I am out of ammo :-( Thank you for any piece of advice...

  • Revoke the USB debugging authorisation in Developer options? That would disable device recognition and may help in getting back the prompt? – beeshyams Oct 26 '16 at 7:09
  • Thank you, tried it, but: no. – Frank Nocke Oct 26 '16 at 7:11
  • Just double checking - is Select USB Config in developer options set to MTP? Even if it is, try toggling it to some other option , Connect USB and toggle it back to MTP? – beeshyams Oct 26 '16 at 7:19
  • 1
    Did you try on a Windows machine also? – esQmo_ Oct 26 '16 at 12:27
  • 1
    @esQmo No Win machine available. But since if worked last week (same host, already under Android 6) and since I don't even see a raw USB device in Ubuntu (i.e. one w/o proper drivers) I think it's unlikely the host is to blame... – Frank Nocke Oct 26 '16 at 14:09

Did you try pulling the notification bar down? You should see "Transferring media files via USB", or "Charging via USB, tape for other USB option" And if after doing all this the problem remains, download Samsung USB drivers from Samsung website.

This screenshot comes from my Galaxy J5, running Android 6 this one too.
Screenshots from my Galaxy J5 (click images for larger variants)

  • precisely that Dialogue is no longer coming up. Also not hiding in the drag-down. The USB device is not even visible as a raw USB device (thus it can imho not be an issue on the host...) – Frank Nocke Oct 26 '16 at 14:13
  • 1
    Did you mind checking the connector? – esQmo_ Oct 26 '16 at 15:05

protected by Community Jun 21 at 13:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.