After trying to root my Moto G (xt1068) and getting stuck in a boot loop, I tried to restore a functioning version of Android and I got stuck in the middle with a re-locked bootloader because I followed an instruction online that seemed to work for some people (...).

So, now the bootloader is locked, the device only boots into fastboot, and has no proper system image installed right now. I cannot access adb because I cannot re-activate USB debugging. Is there any way at all to get this one back to work or did I completely destroy it? I can look up the link to the advice I followed for 'restoring' my device, if that helps.

I am using a Mac but I have access to a Windows 7 PC if necessary.

I had initially used TWRP in the unlocking/rooting process, and it used to work when I first got stuck in the boot loop. Now, I tried 'fastboot boot twrp.img', which did not work ' FAILED (remote failure)', and I tried flashing TWRP again by using ' fastboot flash recovery twrp.img' and I got the following response in terminal:

(bootloader) has-slot:recovery: not found
target reported max download size of 536870912 bytes
sending 'recovery' (8092 KB)...
OKAY [  0.294s]
writing 'recovery'...
(bootloader) Battery Low!!
FAILED (remote failure)
finished. total time: 0.343s

This did not work, as pointed out below. I then tried the further suggestion to flash the bootloader and the gpt. I used the following commands:

fastboot flash partition gpt.bin
fastboot flash motoboot motoboot.img
fastboot flash logo logo.bin
fastboot flash boot boot.img

Upon the last command, I got the following error message:

(bootloader) has-slot:boot: not found
target reported max download size of 536870912 bytes
sending 'boot' (10200 KB)...
OKAY [  0.342s]
writing 'boot'...
(bootloader) Preflash validation failed
FAILED (remote failure)
finished. total time: 0.781s

The device screen gave me this information:

hab check failed for boot
failed to verify hab image boot

Does any of that make sense? I am using the following version of the software:

SW Version: titan_retbr_ds-user 6.0 MPB24.65-34-3 3 release-keysMSM8626BP_1032.3116.99.00R

I tried another version of the Android 6.0 stock image (I got this one through the XDA link: http://forum.xda-developers.com/moto-g-2014/general/official-stock-firmware-t3018682) and I got the same result:

SW Version: titan_retbr_ds-user 6.0 MPB24.65-34 32 release-keysMSM8626BP_1032.3116.99.00R

I thought this was the most current version, isn't it? I had updated to Marshmallow when the update was available, and (if that is pertinent info) I have a German Moto G.

I have found a German version of the Moto G (2014) Marshmallow stock ROM, but it still does not solve the problem. The version is

titan_retde-user 6.0 MPB24.65-34 31 release-keysMSM8626BP_1032.3116.99.00R

Upon trying to flash boot or recovery, the phone itself says "version downgraded for recovery" and the terminal gives me the following result:

target max-sparse-size: 256MB
sending 'recovery' (10280 KB)...
OKAY [  0.349s]
writing 'recovery'...
(bootloader) Preflash validation failed
FAILED (remote failure)
finished. total time: 0.772s

Does that mean that the version I tried was also not the current one? I was not aware that there was anything newer than Android 6.0 for the Moto G, but I will look for more possible ROMs to try. If you have any further advice, I would definitely appreciate it!

  • Can't you just restore the factory image with fastboot? There are several solutions on XDA... forum.xda-developers.com/moto-g-2014
    – acejavelin
    Oct 27, 2016 at 15:48
  • Is any custom recovery installed, maybe even TWRP? TWRP by default comes with ADB enabled.
    – Izzy
    Oct 27, 2016 at 15:48
  • Thanks for the hints, I edited above; I cannot restore the factory image with fastboot, sadly -- it just gives me a short error screen and returns to the fastboot screen. I replied re: TWRP above. Oct 27, 2016 at 16:48
  • You cannot flash TWRP if the bootloader is locked, you need the factory firmware image and must push it via fastboot (not adb). You cannot do it if the battery is under 60% (might be off a little), this your "Battery Low!!" warning. Flash the bootloader and then gpt.bin (partition table), then reboot-bootloader, and continue the normal normal flashing process. Since your bootloader is locked, you must flash the same version or newer of firmware that you have installed.
    – acejavelin
    Oct 27, 2016 at 17:22
  • The log says your battery is low. The flashing process will fail if the battery voltage is under 30%.
    – esQmo_
    Oct 27, 2016 at 20:23

2 Answers 2


The solution was to re-open the bootloader. It is possible to unlock it again by using the code provided by Motorola and the same command I used for unlocking the bootloader in the first place. I did not know it was possible to do that until a friendly person pointed it out to me. After that, I was able to (almost) effortlessly flash a stock ROM, and then (just for trying how it works) CyanogenMod 13.

Thanks for your assistance on this!


I am facing the same problem with my XT1069 and I think it is a problem with the firmware version. I found out that my moto g version is the MPB24.65-34-3 and I was trying to use the MPB24.65-34.

I've just found a site that seems to have ALL versions. Take a look, maybe this helps: https://firmware.center/firmware/Motorola/Moto%20G%20%282nd%20gen-2014%29/Stock/XT1068/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .