0

I need help closing an active connection in Android ADB on a rooted device. I tried everything that stackoverflow and Google can suggest for the past week. I even tried to uninstall the package. It worked for other active apps but not for this one. Any help will be appreciated.

1 active connections Connection Number: 0 Operating Mode: NORMAL com.android.server.display.DisplayPowerController | WakeLockRefCount 0 | uid 1000 | cache size 0 | max cache size 0

  • What app is it? – Dan Brown Oct 29 '16 at 19:56
1

It's not changed in a while, you know.

In fact, since Honeycomb (Android 3.x) You can just run the following in adb:

adb shell am force-stop [PACKAGE]

Of course, replace [PACKAGE] with the package you want to chop up.

| improve this answer | |
  • Force-stop is just one of the things I tired. I tired others which worked on other active apps. And I mentioned this in my original question. – WsdmSkr Nov 1 '16 at 23:24
  • @WsdmSkr Huh. try adb reboot then? – Dan Brown Nov 4 '16 at 9:07
  • Reboot? That just restarts the device and the service is still active when I ran 'dumpsys sensorservice'. Is there any way I can kill this service? – WsdmSkr Nov 10 '16 at 19:25
  • Its unkillable then. Its to do with the screen, so no surprise really - just being hopeful. I'm just gonna ask one thing first: did you use adb root first?? – Dan Brown Nov 10 '16 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.