0

I've just downloaded Kingo Android Root and after some minutes my Moto G 2nd generation soft bricked and now stays in the Moto logo forever.

Since I don't know anything about how to root a phone with safety, I simply didn't enable USB debugging before installing Kingo app. Also, I don't believe this app indeed rooted my phone.

I only managed to unlock my bootloader and that's all. I tried to put the XT1068 firmware.zip file in my SD card in order to apply this update from the SD card but it didn't work. Moreover, when I run the command "adb devices" on OS X, nothing shows up. But when I run "fastboot devices" the prompt returns "0010235101 fastboot".

And of course I tried to wipe cache partition and data, but it didn't work either.

Any suggestions of how to solve this problem will be welcome.

1

Just in case you are in hurry i think you are missing wiping davlik cache and then install zip from sdcard,and make sure the zip is the correct firmware for your device,and also once your bootloader is unlocked, to root your device is not a big deal,search for supersu package on google for your device and install it as "Install zip from sdcard" in custom recovery mode

Full Process:

  1. first of all get the original firmware for your phone ,search the internet using your mobile phone name etc. and please be sure to check that the firmware is the same as your phone's original firmware.(Which i think you already had)
    2.Now if haven't already please install custom recovery like CWM(Clock work mod) or TWRP,i was using CWM.(You also seems to have this from your question)
    3.Copy the firmware to your device or memory card location
    4.Enter recovery mode,Now once in recovery, wipe cache & factory reset, remove davlik cache, and or cache
    5.Now Select the option install zip from sdcard and continue all the verifications.
    6.wait for a while until its done.
    7.Now reboot your phone.
    please note that this information is for successfully recover bootloop(soft brick) for android 4.2 ,while this must be the same steps for your device, please just be sure before proceeding

Not the answer you're looking for? Browse other questions tagged or ask your own question.