0

I'm new to Android 6 and I'm coming straight from 4.2. As my region is with lower celluar network coverage, I'm experiencing problems with my network coverage. Now, the problem is that my Galaxy Note 3 is loosing 3G signal, because the 2G is more common here and 3G is avail only in the city. I can't select "3G (preffered)", like I was able to do in Android 4.2, then when I turn on the Data Connection, the phone will switch to 3G, when I turn it off, it'll go to 2G. I can't do that on Android 6.0, and the phone is in HSDPA all the time.

  • Settings, sim, select your sim settings and preferred network here. – xangua Oct 30 '16 at 21:49
  • No, there are 3 options there. 4G (preffered), 3G, 2G. If I set 2G, then it won't go to 3G when data conn is turned on, instead it'll stay on EDGE. Very annoying... – ricky Oct 31 '16 at 5:56
  • You could create different profiles to change from 2G to 3G and switch in quick toggles. – xangua Oct 31 '16 at 6:07
  • That's an idea, but apparently Android 6 has less options than 4.2/4.4 in that direction. So it can't do that autonomously? – ricky Oct 31 '16 at 10:07
  • Other suggestions? The worst thing is that it won't go to 2G when 3G signal is lost, and I'm 100% sure that there is 2G coverage in that area.. – ricky Nov 1 '16 at 8:00
0

I am using cyanogenmod in my Xiaomi Redmi 1s, I used to do this steps :

  • Open dialer, and type *#*#4636#*#*.(I think this setting code may vary with each device manufacturer, search appropriate code for your device)

  • It will enter into Testing mode.

  • Inside that, tap on Phone Information, look for Set preferred network type, and set it as WCDMA only.

This Setting will be lost after every reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.