0

I think i bricked my phone, my phones model number is "Micromax Canvas Spark Q380".

I've no OS installed, No Recovery Mode Installed.

Also fastboot and adb can't recognise my device on PC.

I've tried this : http://forum.xda-developers.com/gene...k-rom-t3131362 but it also didn't worked.

What to do?? any help please

  • Can you hear a sound when you connect the phone to computer? – esQmo_ Oct 31 '16 at 20:17
  • yes i do but when do process of fastboot, then it says mp device found. – Protonzz Baba Oct 31 '16 at 20:23
  • I don't get you there! You said no OS, no recovery, so the phone is not powering on, or if so, it is stuck in the splash screen, right? – esQmo_ Oct 31 '16 at 20:26
  • it also not displaying splash screen. :( – Protonzz Baba Oct 31 '16 at 20:29
  • its just blank, or dead. – Protonzz Baba Oct 31 '16 at 20:29
0

For IMEI repairing on MTK devices, you'll need a tool called MAUI META 3G and BPLGU modem file

This tutorial explains it better.

2

Unbricking MTK devices is quite simple. You need the stock firmware and the flashtool.

  • Download the firmware here

  • SP Flashtool (the tool needed to flash the files)

  • Extract firmware zip file (I think the flashtool may be inside. If not, download it from here

  • Install USB Drivers. (VCOM or META drivers needed, get them here)

  • Open SP Flash Tool and click the Download tab button, select “Firmware upgrade” .

  • Click Scatter-Loading button & browse to the extracted firmware folder and select MT6582M_Android_scatter.txt file (It is a map file that tells the computer where each files can be sent in the phone)

  • Now hit the Download button.

  • Connect your phone to the PC with battery inside by USB cable (Drivers shall be installed)

  • After the flashing process succeed, a green tick will appear. Disconnect your phone and power it up.

Done.

  • 1
    Ahhh !!! I was skipped to install mediatek drivers, now i installed it and my phone is working like a charm. Thanks :) – Protonzz Baba Oct 31 '16 at 21:31
  • Glad that I helped :) – esQmo_ Oct 31 '16 at 21:35
  • hey wait, all is working fine but my sim is not showing its network. Its in a emergency call only mode. – Protonzz Baba Oct 31 '16 at 21:58
  • Check if IMEI is present *#06# – esQmo_ Oct 31 '16 at 21:59
  • No its not, It says "invalid". – Protonzz Baba Oct 31 '16 at 22:02

protected by Community Jan 20 '18 at 19:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.