6

When I open an app that needs permission to draw over other apps, this screen pops up. But for some reason it is grayed out and I can't allow the app. How can I allow the app to draw over other applications? Why is it grayed out?

My device is Galaxy s7 edge running android 6.0.1

enter image description here

closed as off-topic by eldarerathis Jun 8 '17 at 14:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about writing and publishing Android apps, writing custom ROMs, and other topics that are primarily of concern to developers are off-topic. Consider taking advantage of other resources that may be appropriate for your question." – eldarerathis
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Some app which has this permission is not allowing you . To ist the apps that can draw over other apps, go to Settings - Apps - Advanced (menu with gear icon) - Draw over other apps, disable permission granted to those apps and you should be able to give permission to this app – beeshyams Nov 2 '16 at 11:18
  • @beeshyams Thanks for the reply. Unfortunately, even after disabling all permisions to draw over other apps, it still remains grayed out. Do you have any other suggestions? – Julian Declercq Nov 2 '16 at 12:12
  • Someone says here to restart the device – beeshyams Nov 2 '16 at 12:44
  • @beeshyams Thank you very much for your efforts. Thanks to your comment (that you apparently deleted?) I could actually rethink what I was doing wrong. I am the developer of the app and did not tell you that on purpose: I wanted to know if it was a device related issue or a software related issue. The problem was that my <uses-permission android:name="android.permission.SYSTEM_ALERT_WINDOW"/> line inside my manifest file was between my <application> </application> brackets! I had to put it just before the last line with </manifest>, so OUTSIDE of the <application> brackets. Thanks! – Julian Declercq Nov 3 '16 at 19:26
1

Just had this with an app that wouldn't launch - beeshyams is right, the cause is one or more "enabled" apps that have permission are blocking it - probably not that the problem app needs permission. Go to the list of apps with permission and disable them.

  • Could you possibly explain more? I tried disabling all apps I can (some have the permission locked on, others have it locked off), but no change. Thank you. – nsandersen May 5 '17 at 21:20
0

I tried all the various suggestions on the forums that I read, and unfortunately none of them worked. In the end I did a factory reset, and reinstalled the apps, and so far everything is working OK.

  • 2
    It's 2017 and we're still fixing electronics by restarting them... – owca May 30 '17 at 10:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.