2

Trying to flash TWRP and root my Nexus 5X.

I'm running the N 7.1.1 preview.

I've got the adb and fastboot files downloaded and allegedly working

adb devices 

and

adb reboot bootloader

work as they should.

The Android bootloader info shows that I'm in FASTBOOT MODE, SECURE BOOT is enabled, and DEVICE STATE is unlocked.

But

fastboot devices

doesn't list anything at all.

I'm running windows 10, and when viewing Device Manager, it shows my bootloader-ed nexus 5x as a "Kedacom USB Device" and "Android Bootloader Interface" in the sub list.

But, it won't allow me to replace the drivers with the Google USB Driver, it doesn't even recognize the driver files in the extracted google driver files I downloaded from the Android Studio software.

Not sure what the issue is, but I'm thinking it's an issue with the driver on my end, but then why did the adb half of this work by default?

1

As for my phone (Xiaomi Mi5) the cause of this problem was driver. I couldn't delete driver and istall another one because Win10 install driver faster. The decision was a changing OS on to Ubuntu or Windows (7, 8.1) than device was not recognized. And install drivers from Android SDK.

  • I've got a Debian laptop I can use, I'll see if that works. Thanks. – WorseDoughnut Nov 3 '16 at 16:53
  • Yup, this solved it completely, linux saves the day again. – WorseDoughnut Jan 17 '17 at 14:36
0

after many attempts of uninstalling and reinstalling blah blah I managed to get it working by going device manager > right click kadeacom interface > update > browse my computer > let me pick

then I noticed there was nearly 5 different options (probably from previous installs and such) so saw one listed as 2014 so thought let's give that one a go and it worked! it replaced the Kaedacom with just a general "Andriod device".

So my suggestion to you or anyone coming along this in the future is do the above to load a previous driver you have installed or if you haven't had one before see if you can find one online.

Made an account just to say this so hope it helps someone haha

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.