0

So I have an interesting case with android... Before I start, yes I have done factory resets, I have even tried installing a new ROM. I have replaced hardware. I have replaced the SIM card. But I still have my issue with my phone and only with this specific phone. My Samsung Galaxy note 3 has connection problems connecting with my carrier. My carrier is Family Mobile which is a T-Mobile reseller. I also own four other phones between me and my family who are with the same carrier as me and I do not have the connection issue when I put my Sim in their phones. My issue goes as follows: My phone will randomly disconnect from data. I cannot send texts/call etc. And my phone is basically not longer registered on my carriers network. My APN setting are correct. Although sometimes but not every time when my phone disconnects, I'll see that its then registered on AT&T. Once I re-register on T-Mobile, the phone works for a short while. Sometimes when the last issue does not happen, I'll see a notification that says sign into T-Mobile and I'll click on it and push 'use-network-as-is' and the connection would work again for a short while. There's been a few times where the last two cases don't happen so I'll go into my APN setting and switch between two APNs that are registered to the same servers. Once I switch to the other APN, the networks works again for a short while, I have replace parts inside my phone and the phone still has the issue. This is the only connectivity issue that I have on my phone so that means, NFC and WIFI works just fine.

  • Have you tried flashing whole new system? not installing rom from recovery, but using flash files from pc. – Spark Nov 3 '16 at 20:22
  • I'm not sure entirely sure on what you mean. What I did was I first rooted the stock ROM using Odin on my PC. Then I installed TWRP recovery to install a different ROM of an older verson of Android from Samsung. I have also reinstalled my ROM I think through Odin. But I do know that I used TWRP to install Cyanogen mod. – Lucas Nov 3 '16 at 20:52
  • installing rom through twrp i.e. recovery is different than installing from a flash tool from pc. i know it doesn't make any sense at first but i had few issues with my moto G that i couldn't solve by flashing through twrp but solved by flashing through a flashtool. like spflash tool something. i don't have much experience with Samsung devices but try to learn on xda forums they help a lot in such cases – Spark Nov 4 '16 at 6:24
  • Well I tried my best at that. I upgraded CM from 12.1 to 13 and installed a new kenel. The phone still behaves the same but with the new ROM before I tried the new kernel, the phone wouldn't even see T-Mobile when I tried to register on the network, it would show AT&T and Version witch is weird because its a GSM phone. Would upgrading the modem work? – Lucas Nov 7 '16 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.