When trying to root my OnePlus3 I ran into the issue that when running fastboot devices my output is blank. Some people said that even while it returns a blank output other commands should still work but fastboot oem unlock just says it's waiting for my device without ever proceeding. Also in my device manager I can see ´Kedacom USB device > Android Bootloader Interface´ and I think that might be the problem which I also found in "Kedacom USB Device doesnt work with fastboot Nexus 5x". However no solution is provided here.

When I'm using adb devices after a normal boot it returns List of devices attached 2a04cf0c device and in my device manager I can also see USB devices > ADB interface

  • How do you get to the bootloader mode? – esQmo_ Nov 4 '16 at 3:47

I had same problem with my OnePlus One. Since, I was already on a Linux system, USB drivers weren't the issue. All I had to do is to use prefix the fastboot command with a sudo as sudo fastboot oem unlock.


I had the same problem with a OnePlus One. The problem is that Windows 10 does not let you install the right driver, assuming you are using Windows 10.

I was able to solve it by using a Windows 7 machine instead.

Another solution I found, but haven't tried, is to disable driver verification. This should allow you to install the right drivers, even if the verification fails. However, I do not recommend this as it makes your computer vulnerable to bogus drivers.


Fastboot and ADB requires different drivers. The driver that oneplus provides with the phone doesn't include the Fastboot one. Try to find the fastboot driver, or, if you can't find it, perform your operations on Linux or macOS. These two OSes doesn't require any drivers for using fastboot and adb.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.