0

I have created some busybox aliases in the ~/.profile file, but when I open the terminal app, that script isn't sourced and the aliases aren't available. However, when I manually run source ~/.profile, it is run and then aliases are available. What should I do to source this script automatically each time the terminal app is started.

  • What term app are you using? Jackpal's Terminal Emulator does allow you to set what commands are executed at startup, so it could be a workaround. – Andy Yan Nov 4 '16 at 5:03
  • Yes, I'm using the Jackpal's terminal emulator! Where exactly should I place the commands that can be executed at startup? – Prahlad Yeri Nov 4 '16 at 6:57
1

Jackpal's Terminal Emulator has an option that allows you to set what commands are executed at startup. Go to Preferences - Initial command and put the source command there.

Extra tip: you can't execute more than one line of command from there, but if your command requires su, shortening it with su -c should work.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.