0

I have rooted Lenovo Vibe K5 and i had installed CM 13 (Marshmallow) it was working good cause of some need, i had to install CM 12.1 (Lollipop) and i tried installing through TWRP recovery CM 12.1, I wiped Dalvik , Cache and System and installed CM 12.1 successfully and ask to reboot system and i clicked on reboot and after that it didn't turned on , not even in recovery mode by pressing and holding Volume + and Power button. Then i tried to flash it again with pc but its not showing in CMD as well, it shows the error Device not found in CMD and in windows notification it shows USB Device not recognized. Big Mess . HELP

0

In this state, flashing the stock firmware still the solution. You need drivers for the PC to detect the phone.

  • Click here to get the USB drivers and the flash tool.

  • Click here to get the flash file (firmware).

Alternative download links:

FLASHING STEPS:

  • First download firmware, flash tool and/or drivers from above links.

  • Extract zipped files to desktop or anywhere you'd like (You'll need winrar or 7zip software to Extract).

  • Open Driver folder and choose  Qualcomm_USB_Driver_Setup.exe file and wait until finish installation.

  • Open QPST.WIN.2.7_Installer-00430.1 folder and chose setup.exe file, open and install it.

  • Now open QFIL from the "C:\Program Files\Qualcomm\QPST\bin" path, Select Programmer option and click on Browse button and Select prog_emmc_firehose_8929.mbn from SW Folder file.

  • Click on Load XML button and choose rawprogram0.xml file and then choose  patch0.xml file from the SW Folder folder.

  • Press and hold Volume Up + Volume Down and insert USB cable and wait until driver install are installed.

  • Click on Download button and wait until flashing process finishes.

Oh, and you may need a video tutorial to make it easier, find it here: Flashing process

  • Thanks @esQmo, i installed the driver but its still not detecting my phone in ADB mode, not even in windows , it shows USB Device not recognized :( but yeah it shows the Notification LED indicator light. – Ace Nov 5 '16 at 6:44
  • You can't connect in ADB mode since your phone is off. You have to flash it in this state. Open the flash tool, load the firmware and click on the flashing button then connect your switched off phone with the USB cable to the computer, the flashing process should start. – esQmo_ Nov 5 '16 at 6:52
  • If it's showing "Device not recognized" it is probably the cable is damaged, or the USB connector could be damaged too, or has some dirt – esQmo_ Nov 5 '16 at 6:54
  • in QFIL there's two Build type, Flat and meta build , which one to choose? by default its clicked on meta build, and it does not let me browse programmer path and i'm also unable to find "rog_emmc_firehose_8929.mbn" this file. – Ace Nov 5 '16 at 8:32
  • Can you upload a screenshot? – esQmo_ Nov 5 '16 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.