1

I have a Nexus 6p that is unlocked and rooted. Last night it restarted unprompted (this has happened a few times since Nougat) and it no longer boots into the OS. I get the initial warning about the unlocked bootloader, the white Google logo with the unlock icon, and then it just keeps on rebooting. I powered it off last night and let it rest but that didn't help.

This morning I downloaded the 7.0.0 (NBD90X, Oct 2016) angler image. I tried flashing boot, cache, recovery, and system manually with fastboot and it was still in a boot loop after restarting. I ran flash-all.bat and that didn't help either. I'm not sure what to try next.

Update: I found the hidden menu in recovery mode (hold power+volume up in the recovery menu). Then was having difficulties getting ADB to recognize the phone when I noticed there was a different ADB version running in the background by Droid Explorer. I got that sorted out and uninstalled when I still couldn't get ADB to see the phone when some combination of uninstalling/reinstalling the USB drivers from google and trying different usb ports finally was able to list a device when running adb devices.

So after running wipe cache partition and running apply update from ADB with the latest OTA update (bootloop), and the latest Marshmallow update (Warning: Nofile_contextThis package is for "angler" devices; this is a "".), I'm still stuck.

Update #2: well since I haven't had any luck with anything so far, I tried doing a factory reset with hardware buttons in the recovery menu. Still boot loops. Are there any other options or should I ship it off to Huawei?

Final Update: since no other options worked I contacted Google Fi and they are sending me a replacement phone. Even though I am a few days beyond the warranty's expiration they are sending it free. (I also contacted Huawei and they comically sent me an email telling me to call their support's phone number.)

  • I read somewhere about Android Nougat not letting phones with unlocked bootloader to boot to the OS due to SafetyNet API. You should relock the bootloader. – esQmo_ Nov 5 '16 at 17:04
  • Interesting, I'll give that a try. – travis Nov 5 '16 at 17:33
  • fastboot flashing lock appeared to erase something on my phone but it still just boots to the white Google logo and then reboots continuously. Although no more unlock icon or unlock warnings. – travis Nov 5 '16 at 18:11
  • Now just flash the factory ROM and everything should be fine. – esQmo_ Nov 5 '16 at 18:39
  • FAILED (remote: device is locked. Cannot flash images) – travis Nov 5 '16 at 18:43
2

From what I understand, you said initially that the phone was unlocked and rooted, added to that, since you get the warning message during boot, the bootloader is also unlocked (evidence is the unlocked symbol that comes up at the bottom center of the screen). I used to run into this trouble while rolling back to stock and clearing userdata and cache before the first boot. What you can do again is:

  1. Boot into fastboot.
  2. fastboot erase userdata [or fastboot format userdata]
  3. fastboot erase cache [or fastboot format cache]
  4. fastboot flash radio <<radio img>>
  5. fastboot flash bootloader <<bootloader img>>
  6. fastboot reboot-bootloader
  7. fastboot flash recovery <<recovery img>>
  8. fastboot reboot-bootloader
  9. fastboot flash boot <<boot img>>
  10. fastboot flash system <<system img>> [at this point, you must see it actually recreate the system partition]
  11. fastboot flash userdata <>
  12. fastboot reboot-bootloader
  13. volume up / down and get into recovery mode
  14. Power button + vol up [then let go of vol up, then power] to enter recovery options
  15. use vol up / down and format the device [I believe it's the last but one option]

Reboot device and sit tight for at least about 10 mins.

  • I unfortunately locked the bootloader without realizing what a PITA it would make things. I'm trying to see if there's a way to unlock again but instructions I have found so far require a device that can boot into the OS. – travis Nov 6 '16 at 17:00
  • Please check to see if this is possible: Download the latest TWRP for the N6. I can't link you right now as my office network doesn't allow me to. Then, via fastboot, do a fastboot boot <<twrp.img>> and see if it is able to boot into the TWRP recovery. – blueren Nov 7 '16 at 5:51
  • fastboot boot twrp-3.0.2-2-angler.img downloading 'boot.img'... OKAY [ 0.389s] booting... FAILED (remote: unlock device to use this command) finished. total time: 0.413s – travis Nov 7 '16 at 16:17
  • Oh no. You really are in a bit of a mess. At least for now. Let me see what else is possible. – blueren Nov 8 '16 at 3:05
  • On a locked bootloader, you still should be able to flash google signed OTA / images. Since your phone is in sort of a dead state now, can you format all the partitions via fastboot, do the OTA sideload via stock recovery? The instructions are available here – blueren Nov 8 '16 at 3:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.