2

I have identical problem on two Nexus 5x phones. In last few weeks I've noticed that I don't receive any notification(Gmail, calendar, sms...) when phone is in "sleep mode" but when I wake it up (with power button, shake etc) the notifications show up immediately.

1. I thought there is something wrong with the notifications settings

  • Settings->notifications->configuration:
  • Pulse notification light: "ON"
  • On the lock screen: "Show all notification content"

2. I checked every settings of every app

  • everything is set correctly

3. Battery saver - "OFF"

  • Settings->Battery->Battery saver

4. Doze (battery optimization for apps)

  • Settings->Battery->(drop down menu)->Battery optimization
  • Every app moved to "Not optimized"

(updated)

5. Data Saver - "OFF"

(updated)

6. Keep Wi-Fi on during sleep - "Always"

Settings->Wi-Fi->Gear icon->Keep Wi-Fi


and still...NOTHING :(

I have made a simple demonstration with Calendar event notification: https://www.youtube.com/watch?v=WoCgA1rkq18

Technical info:

  • Phone: LG Nexus 5x
  • OS: Android 7.0 (Nougat)
  • App killers installed: NO
  • Rooted: NO
  • Custom ROM: NO
  • Connection: tried with every combination = Offline, WiFi, Mobile data, Wifi + data

Thx for help and sorry for my english :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.