2

I recently bought a new Galaxy S5 (SM-G900T), updated it to Marshmallow, and have service through Pure TalkUSA on a barebones plan that only comes with 50MB of data. Because of that, I only ever turn it on when I have a MMS that I need to download; I use wifi for everything else.

A few days into using this phone, I noticed something strange happening when I wasn't connected to a wifi network. Even after unchecking the "Mobile Data" box in "Mobile Networks", the Gmail app can still check for new mail, use the internet browser, receive WhatsApp messages/pictures, etc.

The only way I receive a "Not connected" messages in any of these apps is if I turn on airplane mode, which of course means I can't receive any phone calls or text messages.

The only similar post I've found here mentioned data might being used when a call switches from 4G to 3G, however it is supposedly minimal. My full 50MB is used up usually by the second day in my billing cycle, whether I use it or not.

I called my carrier's "tech support" line but they just told me to make sure "Mobile Data" is turned off. When I told them it was, they said it is an issue with a phone and couldn't help me any further.

Anyone know why this is happening? I can't imagine I would be able to do any of these things if I wasn't using data, but I don't know why the phone seems to be ignoring the setting. If it helps, here is the summary of my data usage for this billing cycle (all of the data was used by the second day):

enter image description here

Any help would be extremely appreciated.

EDIT

My current APN Settings are (all others were left blank):

APN:          att.mvno
Proxy:        proxy.mvno.telrite.com
Port:         80
MMSC:         http://mmsc.cingular.com
MM proxy:     proxy.mvno.telrite.com
MM port:      80
MCC:          310
MNC:          410
APN protocol: IPv4
APN roaming
protocol:     IPv4
  • 1
    You could create a APN that is identical to what you are actively using, but only includes APN Type MMS and no other type of connection (especially default and fota), and delete all other APN entries. In theory, you should also be able to leave mobile data on all the time as well too. If you can append your current APN to your current posting, I should be able to create an effective answer. I suspect fota or hipri in the APN type is the real culprit though, they can bypass the mobile data switch in some devices. – acejavelin Nov 7 '16 at 22:51
  • @acejavelin added my APN settings. Thanks for the offer to help. – Human20634 Nov 8 '16 at 18:20
  • Is APN Type not defined, or can you not edit it? – acejavelin Nov 8 '16 at 23:01
  • 1
    APN Type was not defined. Your comment actually made me double-check my APN settings with what was given on my provider's website and after making some changes, it looks like the "Mobile Data" checkbox is now working as it should be. Thanks for the help. – Human20634 Nov 9 '16 at 18:36
0

Check your GPS on the device. Whether it is turned on or off. Sometimes GPS uses a combination of WiFi and Mobile network to determine your exact location. Disable your GPS in order to solve the problem.

  • I disabled all the location services since I got the phone, thanks for the suggestion though. – Human20634 Nov 8 '16 at 20:48
  • Normally it is not the GPS, it is the option to locate the position by known mobile and Wifi antenae. The GPS, on the contrary, does not use Internet. But, of course, phone producers can invent anything. – Gangnus Jul 31 '17 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.