0

The problem:

My Droid Bionic boots to a black screen

How I got here:

  1. Successfully rooted the phone with SuperUser and SafeStrap.
  2. Used SafeStrap to install CM11 into Rom-Slot-1.
  3. Used CM Updater on the phone to install the latest snapshot of CM13 (for targa).
  4. Used SafeStrap to install CM13 on to stock rom
  5. Voila! Boots to black screen.

Solutions I've tried so far:

I still have access to fastboot, and my PC recognizes the phone when it's booted into fastboot.

Can't find any CyanogenMod images to fastboot with, so I started looking for Droid Bionic stock images to flash with fastboot.

I found some and downloaded them. My research shows that RSD Lite is the way to go here, so I've installed RSD Lite v6.2.4. Unfortunately, it does not recognize my phone when I boot it up into fastboot (but fastboot devices still sees my phone).

So I tried manually flashing back to stock using Moto Fastboot as described in this thread:

http://androidforums.com/threads/droid-bionic-fastboot-fxz-files.540725/

Most of those steps worked, but some of them (most notably flashing boot.img) gave me "pre-flash validation" errors.

I tried rebooting the phone anyway and was greeted with a picture of the green android, and blue loading bar. Then the phone rebooted itself and made some sounds (it sounded like the sound effects accompanying the Droid splash screen), but it still shows me a black screen.

I can still boot to fastboot, and my PC still sees the phone when fastbooted.

Any ideas? I'm up for anything at this point.

EDIT:

I have also tried running RSD Lite as Administrator to no avail.

0

I fixed it. Here's how:

  1. Download moto-fastboot
  2. Download the images for stock Motorola Bionic into the same folder you downloaded moto-fastboot to
  3. Open a Command Prompt to that folder and run the following commands:
moto-fastboot flash mbm allow-mbmloader-flashing-mbm.bin
moto-fastboot reboot-bootloader
moto-fastboot flash mbmloader mbmloader.bin
moto-fastboot flash mbm mbm.bin
moto-fastboot reboot-bootloader
moto-fastboot flash cdt.bin cdt.bin
moto-fastboot erase cache
moto-fastboot erase userdata
moto-fastboot flash lbl lbl
moto-fastboot flash ebr ebr
moto-fastboot flash mbr mbr
moto-fastboot flash devtree device_tree.bin
moto-fastboot flash system system.img
moto-fastboot flash boot boot.img
moto-fastboot flash recovery recovery.img
moto-fastboot flash cdrom cdrom
moto-fastboot flash preinstall preinstall.img
moto-fastboot flash radio radio.img
moto-fastboot reboot

My problem was that I downloaded the wrong stock images for my Bionic. I initially downloaded VRZ_XT875_6.7.246.XT875.Verizon.en.US_CFC_01.xml.zip but those image files gave me "preflash validation failure" messages. 6.7.246.XT875 was the previous stock version my phone was on. But prior to rooting, I had upgraded to 98.72.22.XT875, which was not backward-compatible with the previous version. As such, once you upgrade to the latest version, you can never go back to the previous stock version.

The stock images I should have downloaded were cdma_targa_9.8.2O-72_VZW-22_1ff.xml.zip Once I downloaded these images, I was able to run the moto-fastboot commands successfully.

My phone is now running the latest stock version. I don't have root anymore, but that can change :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.