1

This adb command from documentation causes a CAPTCHA to succeed in my favorite alarm clock app:

adb shell am start -n com.urbandroid.sleep/.alarmclock.AlarmAlertFullScreen --ez captcha_result_success true

I tested this command, and it has the expected result. However, I am having trouble achieving the same result from Tasker.

I use the "Send Intent" action with the following settings:

Action -> blank
Extra -> captcha_result_success:true
Package -> com.urbandroid.sleep.alarmclock
Class -> AlarmAlertFullScreen
Target -> Activity

Unfortunately, this doesn't do the same thing as the adb command above. The CAPTCHA screen opens, but it doesn't get dismissed. I'm not sure what is wrong. The Tasker documentation says that the colon syntax is how extra boolean variables are passed.

I've tried a couple of variations, but nothing has given the same result as the adb command.

The adb command is documented here: http://sleep.urbandroid.org/cs/documentation/developer-api/captcha-api/

1

Here is how I fixed it.

Package -> com.urbandroid.sleep

Class -> com.urbandroid.sleep.alarmclock.AlarmAlertFullScreen

You must fully qualify the class and use the part of the package before the slash.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.