7

Not to be confused with applications auto updates.

I have this application as an APK file, once I install the application and choose open it starts working perfectly yet it starts downloading a newest version of itself which I dont want to for a certain reason.

enter image description here

The application is a full screen IPTV application. It runs on an Android box. It can be rooted as it's version 4.2.2. The application has no menus or option, it's not available on the store nor it has a specific name.

Disabling the "Uknown Sources" is not a good solution as I would have the "install blocked" message popping up every two minutes or less since the application does NOT give up on trying to update itself.

enter image description here

enter image description here

Obviously disabling the Internet access is not a solution.

Is there any solution that does not require modifying the APK file itself? I know nothing about Java development and it is impossible for me to modify the source code unless it can be modified to achieve my goal using a for-dummies software like APK Editor

  • 1
    Turn off ye interwebs, then open the app and see if auto-updates can be turned off. – Dan Brown Nov 11 '16 at 9:50
  • @DanBrown would you care to explain a little bit more? Thanks – Ulkoma Nov 11 '16 at 10:01
  • 1
    Turn off WiFi and mobile data (or just enable airplane mode.) Then open the app. find the apps settings menu (wherever that is) and look for an option along the lines of 'Automatic updates' – Dan Brown Nov 11 '16 at 12:55
  • @DanBrown thanks for your suggestion but I believe you have not read my question carefully – Ulkoma Nov 11 '16 at 12:56
  • 1
    @Ulkoma, the Dan Brown suggestion seems legit to me. Doesn't the app have a settings menu? Try find something about update – esQmo_ Nov 11 '16 at 13:52
1

Maybe you can use an app such as Network Connections which has live capture capabilities to find the IP of the update server your app is accessing.

You can then add an entry to iptables to drop the connections to that IP.

For the changes to persist across reboots you'd need a kernel with init support. So you'd have to check that out as well and instal custom one if needed.

PS: I want to make clear that I have no real experience with actually trying any of it and that my answer is just put together from answers I found on other questions on Android Enthusiasts Stack Exchange. In particular, this one and this one.

  • Killing the connection stops the main function of the app, it's a live TV app – Ulkoma Nov 15 '16 at 7:11
  • you'd need root for that – user186920 Nov 17 '16 at 13:11
1
+25

I have 2 methods which I suggest you try out:

  1. Change time and date settings either ahead or behind and see if that could trick the application into not updating itself. Some apps can be auto updating depending on time and date.

  2. Go to phone settings, and open Data usage. Check if the controversial app is listed there. If it's listed then click on menu and Restrict background data.

Now that you have done any of the methods above open the app and try to check its settings to see if has an option to prevent auto updating.

0

METHOD 1

You can disable auto-updates for every application that is installed on the device you're using via the Play Store. Visit the app's store page and at the top there is a 3 dot button that says Auto-Update. This feature is enabled by default and you can disable for each individual app.

But unfortunately, you can't edit or modify the APK itself using a APK editor program because auto-update is made by the device itself.

METHOD 2

In the Play Store, touch the menu button in the upper-left corner of the screen.

enter image description here

Touch “Settings” on the menu.

enter image description here

The “Auto-update apps” option is in the “General” section of the “Settings” screen. If it says “Auto-update apps at any time. Data charges may apply,” then your apps will be automatically updated. To turn this option off, touch “Auto-update apps.” ]

On the “Auto-update apps” dialog box, touch “Do not auto-update apps.”

The dialog box closes and the “Auto-update apps” option is updated with the “Do not auto-update apps” setting. Touch the Play Store icon in the upper-left corner of the screen to go back to the main Play Store screen. You can also touch the Back button on your device.

Hope this helps!

  • The app has not been installed via Play Store, also I have mentioned that it's not auto update, the app is designed to request a newer copy of itself – Ulkoma Nov 12 '16 at 8:29
  • @Ulkoma So, you cannot do anything about it. Because it's integrated inside the app. You can't also edit the APK as I've mentioned. But you can try to edit. I don't have much experience about editing APK's but you can only try. And a question, is this app has a bigger size that you don't want it to update itself? – Arda Çebi Nov 12 '16 at 8:34
  • never say never, maybe someone will come up with a way to disable the system notifications or a firewall to block the download. No idea about the size – Ulkoma Nov 12 '16 at 8:48
  • @Ulkoma maybe... :D – Arda Çebi Nov 12 '16 at 9:27
0

Its depend on your Android version. If you carrying least lollipop, you will get an option in setting. Or you can simply visit to play store by searching your app. There just disable the auto update option.

  • The app is not in the store and it has no options, it simply requests a new version of itself and invokes the installer, any idea how to defeat that? – Ulkoma Nov 13 '16 at 17:08
0

Use this App Mobiwol Which,

  • can make enable/disable each/all app to connect/disconnect the Mobile data/Wi-fi/both.
  • Block background app activity

To do this, just Slide the firewall to enable

(Click image to enlarge)

IMG: Mobiwol App Connectivity Permission

The Blue highlighted one in Fig. 2 shows the App is allowed to connect.

Note: No root is required & works from version 4.0

-1

you can use root explorer and edit system files. first you should root your devices. you can use Kingroot for rooting the device.

protected by Community Dec 24 '17 at 9:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.