Let me explain the situation : I have a old SM-G350, perfectly working. I just removed all Google/Samsung preinstalled things to make it look "clean". My goal was to install Linux on it, and I've done this by running Debian 8 on it with "Complete Linux Installer" app. So, all is working fine here. By SSH, I manage this Debian with my PC. My phone is rooted.

I ran into a trouble today : I was trying to enable the monitor mode for the wlan0 interface. With airmon-ng I ran the following command :

airmon-ng start wlan0

And I get this error message :

bcmsdh_sdmmc - [phy10]mon0: ERROR while getting interface flags: No such device

So, I don't know what to do. I've tried this :

Any help would be great, I'm totally lost here !

Further information

If I run netcfg, I get the following output.

rmnet0 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet1 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet2 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet3 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet4 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet5 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet6 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet7 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet8 DOWN 0xffff8080 00:00:00: 00:00:00
rmnet9 DOWN 0xffff8080 00:00:00: 00:00:00
ip6tnl0 DOWN 0x00000080 00:00:00: 00:00:00
lo UP 0x00000049 00:00:00: 00:00:00
sit0 DOWN 0x00000080 00:00:00: 00:00:00
p2p0 UP 0x00001003 02:12:36: ed:7a:b4
wlan0 UP 0x00001043 00:12:36: ed:7a:b4
tunl0 DOWN 0x00000080 00:00:00: 00:00:00
  • did you try eth0 instead of wlan0 ?
    – esQmo_
    Nov 13, 2016 at 17:16
  • I don't have eth0 since it's an Android phone-based.
    – Zirfly
    Nov 13, 2016 at 17:42
  • Did you try? Some phones have their wireless interface named eth0. If you have BusyBox, try busybox ifconfig -a
    – esQmo_
    Nov 13, 2016 at 17:53
  • I tried, I don't have it. I guess it's logic ?
    – Zirfly
    Nov 13, 2016 at 18:03
  • Or as suggested in the comment below, your chipset doesn't support monitor mode. What is the output of netcfg in ADB shell?
    – esQmo_
    Nov 13, 2016 at 18:08

1 Answer 1


This is something I also wanted on my Nexus 5, but after doing some research I found that for enabling monitor mode on your android device your chipset must have monitor mode. In case the chipset doesn't support it, its not that easy to get this enabled. The supported chipsets as of now are broadcom 4329 and 4330 WiFi chipsets. Though for Nexus 5 by making some modifications in the kernel, some developers on XDA found a way out. What seems the reason for getting it specifically for Nexus 5 is that this device still has development going on till date. For your device unfortunately its chipset doesn't come up to be supporting monitor mode.

  • But the SM-G350 seems to have the Broadcom 4330 chip ! So there is a way to do it, no ?
    – Zirfly
    Nov 13, 2016 at 18:04
  • As I also mentioned there should be development for your device, the driver and kernel should be modified/developed accordingly. There's a link though if u wish to get more info - bcmon.blogspot.in/2013/01/new-firmware-for-bcm4330.html?m=1
    – Phoenix
    Nov 13, 2016 at 18:27
  • Thank you. I see someone telling to "compile your own driver", is it a way for me to get it working ? If I need to this, I'll do.
    – Zirfly
    Nov 13, 2016 at 20:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .