1

I encrypted my device on a lark, but it affected performance too much. I want to decrypt my device, but the place where I could previously initiate the encryption now just show "encrypted". I tried a factory reset both from the setting and from TWRP, but after the device boots back up, it's still in the encrypted state. Tried several times.

5
  • 1
    Have you tried TWRP's "format data" option? They implement factory reset by deleting (with rm) files from the filesystem, which wouldn't affect its encryption state. Formatting should actually create a new blank partition which would be unencrypted. It will delete everything in /data, though, whereas the factory reset in TWRP doesn't delete things like media, downloads, etc. Make sure you backup anything you want to keep to another device. Nov 14, 2016 at 20:57
  • This has worked for one of the two phones I encrypted (and +1 for that), but the other doesn't have the "wipe data" button in TWRP. I can select "data" as part of the wipe but it seems to leave the encryption status untouched.
    – retorquere
    Nov 14, 2016 at 21:45
  • Odd. What's the other phone, out of curiosity? Nov 14, 2016 at 21:51
  • One is an LG G2 (which I managed to decrypt now) the other an Samsung Galaxy S2 (i9100). Both on CM13 and recently updated, although the TWRP for the i9100 is not as frequently updated (and no wonder).
    – retorquere
    Nov 14, 2016 at 22:06
  • The odd thing is that in TWRP, I can see the wipe saying it's ext4-formatting the data partition.
    – retorquere
    Nov 14, 2016 at 22:07

1 Answer 1

0

You will have to wipe userdata using fastboot mode.

fastboot erase userdata
3
  • Sounds reasonable, Rohit – but could you please edit and include the steps required (boot to fastboot/bootloader mode, attach the cable etc.) and requirements (Android tools installed on the computer; you can link to our fastboot resp. adb tag wikis for details, and thus don't need to be too verbose)? Not that I think the OP needs that, but other users might :) Thanks in advance!
    – Izzy
    Nov 15, 2016 at 7:17
  • 1
    Also @eldarerathis♦ solution should at least be included in the answer. For most people on a current TWRP, it's going to be the preferred method.
    – retorquere
    Nov 15, 2016 at 10:07
  • 1
    @Izzy yes good idea.. I will be compiling and doing the same shortly.
    – Rohit
    Nov 15, 2016 at 13:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .