2

I'm coming to a Pixel from an iPhone. When I set up the Pixel, I imported my messages (using the switch process) and contacts (synced through gmail), among other things. However, I wasn't aware that my iPhone contacts were all saved in Google's Exchange account (not gmail), which no longer exists (as of 2012). So when I imported my contacts from my iPhone, every contact I had added since Google migrated away from exchange was not added. To fix this, I exported all my iPhone contacts as a .vcf (using an app) and then imported them to the Pixel.

It seemed to work smoothly, as all my contacts were now showing up in the contacts app. However, in my messages app, I am still showing phone numbers instead of names for all my contacts that were imported through the .vcf--even though google associates those number with their correct contact when I click on the image/letter representing the person in the chat. It also shows the persons name on the lock screen when I get a message--but again, just shows their number at the top of the messages app when texting them. How can I get messages to show the contact name and not number at the top of messages? Should I not have imported my messages?

Related, but outdated: Contact names not showing for the calls and messages

  • Why did this question get downvoted? – spacetyper Nov 15 '17 at 3:53
3

After a long support session with Google, some combination of the following things resolved the issue: (although it was unclear what happened when because there were numerous glitches that occurred throughout the process which were corrected by clearing data and rebooting)

  • Force closing the contacts and Messages apps and restarting the phone
  • Clearing the cache of the Messages app
  • Clearing the data of the Messages app (note: this does not delete all your conversation threads as I feared it would. The warning may sound ominous, but at least for me, all my conversation threads were resynchronized following the data clearing and reopening the Messages app).
  • Going into settings of the Messages app, and changing the default SMS app to Hangouts, and then back to Messages (note #1: this requires the Hangouts app. note #2: upon opening Hangouts I was prompted to try the Messages app--I hit OK and this fixed >50% of my contact formatting issues)
  • Rebooting the device

This was on a Pixel with Android 7.1 and Messages 2.0.

  • This happened to me when I got my new Pixel 2 after RMA'ing my broken one. The only thing that helped is "Clearing the data of the Messages app" as you said. And it did NOT delete all my information. Thanks! – kmort Sep 15 '18 at 4:42
1

I had the problem changing to a pixel xl where some names would show up and others would be phone numbers. There is an easy fix! Change the color palette of the person sending the msg and their name will show up instead of their phone number.
Don't know why it worked but it does.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.