I'm using Samsung Galaxy S7 Edge on Android 6.0.1 (Build Number MMB29K.G935FXXU1APGO). So I have a relative who's spending some time on the other side of the planet (Japan). To facilitate communication, I had set up a dual clock a while back to show both, local and Japanese time on the lock screen. Now - probably due to some update or other - it doesn't show up anymore, just local time.

I checked the settings and it's changed. "Dual clock" is still turned on but I cannot select what times to display, anymore. Instead, the option now reads "show both local and home time zones when roaming" (unless that's a different clock, in which case I'd like to know where the other went).

I tried setting my home time zone to Japan, but that didn't trigger dual clock -- my guess is because I'm not roaming. Disabling automatic date and time doesn't change anything either.

How do I turn dual clock back on?

1 Answer 1


I believe that the Dual Clock only works when you are roaming. I could be wrong of course, but last time I left the UK the Dual Clock only appeared when I was connected to an internet connection and was in the location; when I got back into the UK the Dual Clock completely disappeared, and it hasn't turned on since. Hope this helps :)

If you're happy to not have Dual Clock you could just check the Clock app; but I'm sure you're not happy otherwise you wouldn't have posted this.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .