1

My phone is suddenly stuck at "Obtaining IP address" when trying to connect to a WiFi. I've tried rebooting, deleting and re-adding the WiFi networks, restarting the router (all other devices connected to the router work fine), to no avail.

I'm running Android 7.0. I'd like to avoid a factory reset, so if anyone has an idea what else I could try, I'd appreciate it.

  • Hard to say, but some details from the logs might help. Please check with our logging tag-wiki for ways to get logging information. If you succeeded, please edit your post with your findings. Thanks in advance, and good luck! – Izzy Nov 17 '16 at 16:56
2

Beginning with with Marshmallow (possibly Lollipop, I was on it for such a short time I can't remember), there is an option in Settings, Backup & Reset called "Network Settings Reset" described here. This will reset all network settings only in the device, leaving other data intact. Note that all your WiFi passwords and any security certificates will be removed as well, but this will often correct the error you describe.

0

I had this problem across Android Gingerbread, KitKat and Marshmallow and solved it by changing my router's operation mode from 'Auto' to 'n only'.

All of my devices support on 802.11n. Don't know exactly why the android was not connecting when the setting was Auto (Read on the internet that there can be interference issues due to other RF signals). But changing over to specific mode helped.

My router model is ASUS which supports 802.11b/g/n. Slightly old. New devices with 802.11ac support might work flawlessly but they cost a premium at this moment.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.