5

The ring for 5 minutes function on Android Device Manager is a great tool that I have used multiple times to find my phone (which I happen to misplace quite often).

The thing is, it doesn't work. Or rather, my phone will not ring even when given the cue from Android Device Manager to ring. I have it set up on my phone, and am able to locate my phone just fine. However, when I click ring, my phone beeps once, and there is a notification that says "Android Device Manager" with the subheading "Ringing...", but my phone never actually rings.

Does anyone know why this happens, or better yet, how to fix this? Any help would be great.

I have a Samsung Galaxy S6, and yes, Android Device Manager is set as an administrator on my phone.

edit: Upon looking into the Phone Administrator settings in Security, I found that the permissions do not mention anything about ringing the phone (https://goo.gl/photos/gt1iE6piQTVfYvnHA). Is this because that permission isn't at the administrator level, or do you think it is unavailable for some odd reason?

Update: So I managed to figure out that the only way it will ring is if my notifications volume is on. However, I don't usually have that on, and it will not turn that volume on full or even on at all by itself.

I also disabled battery optimization for Device Manager, but unfortunately it does not seem to do anything.

  • It may be that Samsung has an internal battery saving mechanism which prevents the device manager from receiving the notification. Idk if you can disable it for some apps... – Timo Schwarzer Nov 23 '16 at 22:11
  • @timoschwarzer What exactly do you mean by it preventing device manager from receiving the notification? – Mario Nov 23 '16 at 22:55
  • I assume that you have access to a phone because you know it doesn't ring. Maybe, just maybe this will help: settings>apps>android device manager and under permisssions see if some isn't granited. You can try clearing app cache and rebooting. Also try setting notifications on priority for ADM maybe do a trick. – Једноруки Крстивоје Nov 24 '16 at 0:18
  • @ЈеднорукиКрстивоје I already set notifications as priority and it doesn't work. Also, I tried looking at the permissions before as well and all of the options are enabled. I also tried uninstalling and reinstalling the app, which unfortunately doesn't work either. Im honestly not sure if there is anything that I can do, but hopefully there is a fix – Mario Nov 24 '16 at 0:35
  • Well, maybe it's just temporarly. Try finding older version on google, and see what happens than – Једноруки Крстивоје Nov 24 '16 at 0:42
1
+100

This issue seems to be caused by Android Device Manager not being able to raise the ringer volume on your phone before ringing the alarm tone.

To solve this, you can create a MacroDroid macro that will automatically raise your ringer whenever an Android Device Manager notification appears on your phone, so that the alarm tone will actually ring. MacroDroid defines a set of trigger(s), action(s) and constraint(s) as a macro.

  1. Download the MacroDroid app for free on your phone.
  2. You will need to create the following macro:

    • Trigger: Notification → Notification Received:

    • From: (hit show non-launchable apps) and select Google Play Services and Android Device Manager

    • Text Content: choose contains and type in "ringing" (or just some/all of the text from the notification that appears when you attempt to ring your phone; this might vary by phone).
    • Action: Volume Change

    • Hit the checkbox next to "ringer" and slide the ringer slider up to something high, then press OK. Then hit the checkbox next to "Notification" and slide the notification slider up to something high as well.

    • Constraints: none
  3. Test out your Macro by attempting to ring your phone from Android Device Manager on your computer. If it works, you're done. If it doesn't, try the following:

    • Add an action to your macro to Set Priority Mode, set it to all.
    • Add an action to your macro to play a sound of your choice, that might work.
    • Ensure the Device Manager notification text matches that which you specified in your trigger.
    • Try changing the action to a ringer volume increase, a one-second wait, then a notification volume increase.

Important Note: If you want your ringer to quiet down again after Android Manager rings, you can add a wait before next action to your actions, then do a ringer volume change back down.

Hope this helps! Comment below if this doesn't work for you or if you have a question, I'll help you out if you need it.

  • When I try to install that macro it gives me an error... also I tried making my own and it works when I click test macro but nothing happens when I actually get the notification from Device Manager. – Mario Nov 30 '16 at 12:02
  • @Mario Have you enabled notification access for MacroDroid? Did you make any notification from Device Manager trigger the macro? – owlswipe Nov 30 '16 at 12:06
  • yes to both of those – Mario Nov 30 '16 at 12:07
  • @Mario Make your macro also send a notification as one of its actions, this will let you know when it runs. See if it runs at the right time. – owlswipe Nov 30 '16 at 12:17
  • It doesn't run at all, for some reason it's not realizing I'm getting a notification from Device Manager, because I don't get a notification at all from MacroDroid – Mario Nov 30 '16 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.