Just want to say I've read just about everything I can find about this Marshmallow 6.0 adopted storage issue.. The most helpful of all of the different slight variations on the same answer was: How to decrypt Adopted Storage?

I've followed it, but I'm having problems. So I'm here to ask some for some clarification. Any help would be greatly appreciated!

The current symptoms:

  • SD card not recognized by phone
  • when inserted into my mac (i'm using terminal in el capitan), it shows up in disk utility but it's not mounted (can't be opened)
  • on running diskutil list I can see the card as shown below:

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *32.0 GB    disk2
   1: 19A710A2-B3CA-11E4-B026-10604B889DCF               16.8 MB    disk2s1
   2: 193D1EA4-B3CA-11E4-B075-10604B889DCF               32.0 GB    disk2s2

So, what I've done so far:

  • My phone was already rooted, so I was able to extract the encryption key.
  • I used the guide to convert it to hex, yielding 7342560bad2454835235517e6a0df2f0
  • So, with the sd card plugged in to my mac, I try to run the command:

dmsetup create crypt1 --table "0 'blockdev --getsize /dev/disk2' crypt aes-cbc-essiv:sha256 7342560bad2454835235517e6a0df2f0 0 /dev/disk2 0"

  • As you can see, I replaced the /dev/*** portion with my own finding, and the encryption key with my own... So far so good?
  • Now, this is where the confusion comes...
  • This is what I get when I execute the command

-bash: blockdev: command not found

-bash: dmsetup: command not found

  • Since it says to ignore any errors, I did so (although I feel like these errors are a bit different...), but upon executing the following command mount -t ext4 /dev/mapper/crypt1 /mnt/1/ I'm told: mount: realpath /mnt: No such file or directory
  • So obviously it didn't work, but I'm not exactly sure where it went wrong.
  • After a little research I discovered that maybe my path might be incorrect for terminal, so I tried executing export PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin and then tried re-executing the decryption command, but it yielded the same results.

I've been scouring around looking for information, but I figured it might save me some strife to just write it up and see if anyone with more wisdom in this area help point me in the right direction.

Thanks in advance for your help!

(Oh, and just as a side note, I'm trying to get my phone back in working order, but I don't want to ruin any chances of being able to recover the data from the sd card. So the question is, now that I have the encryption key and the sd card out of the phone, is it safe to flash a new rom and start over? Or is there still other data on the phone that's important to keep around during this recovery process?)

EDIT: I followed the user's comment below, I'm using ubuntu with virtual box, but when I run commands to find all attached devices, my card isn't showing up like it does in the Mac Terminal. Any ideas why that's the case?

EDIT 2: Here is a picture of my terminal in Ubuntu trying out the command. Any clues as to the errors? Here is a picture of my terminal in Ubuntu trying out the command. Any clues as to the errors?

1 Answer 1


MacOS is not GNU/Linux it's APPLE/BSD so use Ubuntu in VirtualBox, or get ypur Phone to mount it and copy it from there.

  • AH! Okay, I was under the impression that all the commands were compatible because some of the ones I was using from the guide seemed to work... but this makes sense. Now to figure out how to use the Linux terminal. I haven't tried more than once, but so far I can't get Ubuntu to recognize that my card is inserted at all. It shows up in Mac's terminal as I posted above, but so far I can't get it to show up in Ubuntu... Maybe I'm using the wrong command? It's not technically mounted, so maybe there's another command to show all devices including those inserted but not mounted...?
    – c.w.
    Nov 24, 2016 at 3:30
  • @c.w. you need to explicitly attach it superuser.com/questions/373463/… Nov 24, 2016 at 14:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .