19

Google Maps always shows me distance values for direction results / navigation in miles, although it does show me a scale on the map itself in metric units. I rather prefer to get my direction distances in metres/kilometres. Is there any way to achieve this in Google Maps? I searched a bit for this and suggestions seem to be to change locale in Settings > Language and Keyboard. Mine is currently set to English UK.

8 Answers 8

3

It's 2015. In Android I can choose distance units for Maps. It defaults to automatic. For some reason, automatic gives my results in miles (I live in Australia). Navigation is metric. But anyway, if I choose Kilometres instead of automatic, I get kilometres.

6

I'm in Canada and recently made a road trip to the states. When I'm planning a trip starting in Canada, the whole trip is in km, even if it crosses into the US. If the trip starts in the US, however, it shows everything in miles, even if it crosses into Canada. It appears that it's not the location set in your phone but rather the location of the phone itself (if using "my location" as the departure point - otherwise it's just the departure point).

You can try this out by plotting a trip from a "miles" country to a "km" country and then clicking the reverse trip. The units changed with me.

1
  • 1
    UK is weird then because despite technically being a "km country", miles are commonly used for driving. Commented Jul 26, 2012 at 13:36
3

Unfortunately, I saw no way to post a comment to your question though this is not really an answer:

I am spanish and therefore my Samsung Galaxy Tab is configured for my country. When using the measure ruler from the labs tab of Google maps I get all the distances in metres/kilometres instead of miles.

So it seems that changing the locale might help

3
  • But that's only for the labs direct measurement tool, isn't it? Does it work for working/driving directions too? Commented Nov 30, 2011 at 22:27
  • @AnkurBanerjee - there is a system-wide Locale setting.
    – TomG
    Commented Dec 1, 2011 at 2:19
  • 1
    @TomG: Correct, I've set it to English UK, but that doesn't get me metric units in the map. Commented Dec 1, 2011 at 10:35
1

Open settings:

enter image description here

There is a parameter to configure the distance units:

enter image description here

1

You can just change the language for example from English US to English NL, a country with different metrics.

0

I am Spanish and therefore my Samsung Galaxy Tab is configured for my country. When using the measure ruler from the labs tab of Google maps I get all the distances in metres/kilometres instead of miles.

0

On Xiaomi poco M3 settings there is no option for units in settings. After changing language, Maps still showed distance in ft miles. I had to go to settings / apps /maps /storage and delete data. After that distance changed to m / km

-1

Try changing in the Google search bar: Settings -> Google now -> Weather -> Change from Fahrenheit to Celsius.

1
  • 2
    What does this have to do with length? And pointless for Maps anyway. Commented Jan 27, 2013 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .