1

I have tried a lot to unbrick my Lenovo Vibe Shot. Now I am helpless and looking for some workable solution:

I used Lenovo Smart Assistant to download a proper firmware so it turned out it is: z90a40_USR_S363_1606250500_Q202533.1_ROW.zip

I tried to use Lenovo Smart drive assistant to update ROM or Device Rescue, but both wont detect phone. The phone default Lenovo recovery can be loaded by pressing VOL+, VOL- and power button, and then releasing power button when logo appears. I used an Update.zip in 8GB mem card and used the option: ‘install update package’ then it complete the process 100% I was happy that I was going to get my phone unbrick

After trying a lot of things I realized the actual problem is with partition table of its internal memory, so whenever I try to connect phone via USB cable to PC and turn it on simply with power button or trying with fast boot mode (VOL - and VOL + then pressing power), it shows all the following partitions that are write protected. So is there any way I can forcefully remove the write protection and delete all these partitions ??? I have tried with Disk part as well but no luck. Plz help PS if some one wants to read more about this problem, plz check following thread of mine that is still unreplied: http://forum.xda-developers.com/android/help/unrbick-lenovo-vibe-shot-z90a40-t3505789

Partitions shown in My Computer

1

I figured it out from my semi-sleepless nights. But b4 the solution that worked for me, I had to learn a lot out of my desperation to finally get it worked on the day I decided to hand over to some technical guy from local market

The full comment form Francisco Kadzi helped me finally do it from following youtube link: https://www.youtube.com/watch?v=SmMg00Wqabc&t=1s

Besides I had to take care of many things. First here are the things I was doing wrong:

  • Not taking care of a heavily charged phone, I would try to unbrick after just 1 hour or less charging from a total uncharged device.
  • I was going to a backward step whenever I failed on something (Reboot in fastboot mode, trying with QFIL etc.). Whereas many different forums (mainly XDA), people were saying to try again and again.
  • I was using improper ROMS or flash files my device was: Z90a40_USR_S363_1606250500_Q202533.1_ROW
  • When I would see 9006 mode again I would be disappointed and would try different solution. The correct thing to try was uninstall this driver and then connect the device again with PC in fastboot mode .

Then I used Lenovo Smart Assistant and got this proper file: Z90a40_USR_S363_1606250500_Q202533.1_ROW

OK read my first post to know what problems I faced, but at the end the multiple partitions were not really the problem. The actual problem was getting 9008 mode in Device Manager of my Windows 7. I always got it as Diagnostics 9006 mode. One I started getting 9008, things went in my way gradually. So the person posting on above comment from youtube link helped me

Am a happy fellow at the moment and will help anyone with same problem if needed

My email id is: usman400 on G Mail

1

Been there, done that.

I took me almost 15 days to research, try, and experiment and finally I was able to revive my Lenovo.

Basically, you have messed up the partition and now all you need to do is to delete them. try MiniTools to delete partition, it is a free to use software.

You are not able to delete partition from windows, because for that you'll first need to have your Windows in TEST MODE. without that, I don't think you'll be able to delete any of the partition.

Next is you'll have to check in which "Hard-Brick" mode your device is: OLD or New. Because recovering process for both modes are different. There are lot of other things you'll need to do before actually getting your device back.

I have also made a "TL;DR" kind of tutorial for the same problem. I don't know if I am allowed to post my blog links here or not, I am new. But anyways check the below link from Step 1 to getting your device back. http://www.dotandroid.com/android-root-guides/unbrick-qualcomm-mobiles/

  • If you are promoting your own web site, you need to be explicit about it. See how not to be a spammer. – tripleee Apr 27 '17 at 11:20
  • Not promoting, but I have personally faced the problem mentioned in this post. Inspired from that, I have made that post. The post is too big with lots of images, so it was no point copy pasting it here. If it is not allowed, I can delete the link. – Dot Android Apr 27 '17 at 11:25
  • I guess this is fine. Just be careful when posting links to your own content, and make sure the answer is useful even without the link. – tripleee Apr 27 '17 at 11:32
  • Yes, sure. I have edited my answer with all the basic possible information I can provide. Rest is a lot technical things. – Dot Android Apr 27 '17 at 11:32
0

Actually I bricked my phone a whole lot of times even after my post. That's because once I knew that it is just soft bricked and I can get it back somehow, I got the confidence and tried advanced things that bricked my phone again and again.

And it was only the recent time (around 3 weeks ago) that I figured the 100% working 9008 method for my phone.

Actually you have to drain the battery completely out. Then it will get into 9008 mode. To do it youu need to try turning your phone on again and again so that the battery goes off.

For example: Press Power button for a few seconds to turn it on.

Or press 3 buttons at same time (VOL+, VOL- and Power), then release only Power button when you get vibration. Then after 2 seconds release both VOL buttons as well (this is for going to recovery mode).

This way you can drain the battery of the phone completely, and you will know when the battery is all gone when you press the Power button and the phone will not show any LED light or screen light, it will just vibrate and stay turned off.

Now you connect your phone to a PC in the following way:

If at bricking you you were on Lollipop (Android 5): Pressing VOL+ key and plug the USB cable in without pressing the power button. 9008 will open. Use Qfil to flash the ROM you want.

OR If at bricking you were on Marshmallow (Android 6): Plug the USB cable into the phone, then connect the cable to a PC and exactly at the same time press the power button (sometimes you don't need to press the power button so try with both options). Then if you see 9008 mode in Qfil, immediately press the Download button in Qfil.

If you see an Qfil error then repeat the above process to get 9008 mode and use miflash instead of Qfil. Miflash worked for me better than Qfil because Qfil often gives error in between.

And when you get the flashing 100% then phone will either auto restart or you have to restart it manually. Using Qfil it shows you a message when it is restarting the phone, and I think using miflash it just says process 100% complete. Then you have to restart the phone yourself.

Remember at this point (after restart) connect your phone charger properly into an electricity power socket instead of to the PC as the battery was already drained -- you need to charge the device while it shows the long booting process due to the newly flashed ROM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.