1

I can set Nova Launcher as default launcher in Settings -> Installed Apps -> Defaults -> Launcher, but whenever I tap the home button, the device loads the system launcher. In the settings of Nova Launcher I keep getting the following message: "Not set as default - Nova launcher is not set as the default launcher. Tap to set."

I tried all combinations of rebooting / re-installing / clearing caches and whatnot. It all doesn't help.

0

Got it after some research.

  1. Make sure developer options are enabled: Settings -> About Phone -> MIUI Version, tap it 7 times (no kidding). Should turn on the developer options.
  2. Turn off MIUI optimizations: Settings -> Additional Settings -> Developer Options -> Turn on MIUI optimization: Turn it off.

Next time you'll use the home button with your custom launcher running, the system will ask you what app to use for the "home" action. Just select your launcher and set "remember my choice". From now on the settings will stick.

See also:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.