I'm using Android 6.0 (non-rooted) phone. Holding home button opens up Google App which I never use.

I don't think that I can change the behavior of holding home button at least as non-root user. (If there's any way or work-around then don't forget to tell me!)

So, as I never use Google App and also want to stop opening Google App by means of home button, I want to disable it as it is a system application hence I can't uninstall it.

But when I opened Google App from system settings, I found disable button is disabled:

enter image description here

So, How do I disable Google App or there is no option except root?

By the way, it is also not being force-stop with the help of force-stop button!

  • Rooting is a key to gain privileges like reputation is for this site! – Pandya Dec 3 '16 at 16:06
  • You must be rooted. – MANI Dec 3 '16 at 17:16
  • Have you tried adb shell pm hide com.google.android.googlequicksearchbox? – Firelord Dec 3 '16 at 17:39
  • @Firelord no. I'm not familiar with adb. – Pandya Dec 3 '16 at 17:56
  • Have you tried opening the Google app, settings, direct search, disable? – xangua Dec 3 '16 at 20:17

You can change the behavior of holding home button even as non-root user (at least on my LG G Flex 2 with Android version 6.0.1):

Settings - Apps - Configure apps - Default Apps (in Advanced section) - Assist & voice input - here touch the text "Assist app Google app" not the icon on the right edge - here select None.

| improve this answer | |
  • Though the answer is not about disabling Google App actually but as it solves my issue, I've accepted. +1 for helping out – Pandya Dec 22 '16 at 14:51
  • Worked for me (stock Miui10), 2 years after the answer. That is, these steps helped disassociate the Google app from the home button on my phone (center button for me). – Samveen Oct 19 '18 at 3:01

I was able to finally disable the Google App by updating the app then uninstalling the updates from the 3-dots menu in the top right. This caused Android to present the Disable button.

| improve this answer | |

Clear all the data of google app then Go to play store > options> My apps & games.

My 'Apps&games' >

Go to 'installed'>Google app > uninstall

Now don't do anything it will show to two options 'update' and 'open' minimize and close play store.

Then head to the settings > storage & USB > internal storage > Go to google app.

Now you should be able to disable it.

| improve this answer | |
  • How do you "minimize and close" Play Store? This isn't Windows. – Dan Hulme Dec 19 '17 at 13:38
  • After uninstall, app(user app) is completely removed from your app list. Then, how can you disable it. – Rahul Gopi Dec 20 '17 at 8:25

I went to Settings, Apps, Google App, then Modify System Settings, then switched off Allow modify system settings. I could then force stop the app, and disable it. The icon even disappeared from the app drawer with a refresh of the launcher. Android 7.1.1.

| improve this answer | |
  • There is no such option in Android 6.0 – Pandya Dec 8 '18 at 4:04
  • I tried Carl's suggestion above on Android 8.1. It worked. However, the Google launcher didn't launch. I had to pull down the menu at top, go to settings, apps, and enable Google Play Store. The Google App was enabled again also. Maybe with another launcher it would have worked. (On the 7.1.1 I had another launcher, Apex). – Dougo Dec 8 '18 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.