0

I want to root my HTC One M7, but it is branded by Verizon. When I got to:

Settings>About>Software information, I have:

Screenshot 1

When I click More, I have:

Screenshot 2

I had root from the app Kingoroot (yes with the O), took Security update from Verizon, and lost root. Now Kingoroot always fails. Kingroot (without the o) works SOMETIMES, but then my phone reboots either when I try to do something root-related, or after about one minute. I have tried several other One tap and One click apps/programs, but the ydo not work. Here is a list of what I have tried:

Kingroot (PC & APK) Kingoroot (APK, for some reason I get a 500 error when trying to get the PC version) Framaroot (Says not vulnerable) z4root (Just installs inapropriate apps) iRoot Weaksauce Wondershare TunesGo Towelroot

Rumrunner fails with either "Such dumb issues you have" or "F* it". 1. Why is this happening

  1. How do I fix it

I do not have $25 for Sunshine

I really want my phone rooted. I do not care if it is by one click, or by somehow getting a custom recovery and ROM. I would rather the recovery and rom, specifically TWRP and Cyanogenmod.

Thanks for any help. I will provide more specific information if requested.

PS. I forgot to add: I have access to ADB, fastboot, and can even set up adb to use by localhost From computer: adb tcpip 5555

And from the phone itself (I use Material Terminal Emulator): adb connect localhost:5555

  • Is your bootloader unlocked? – esQmo_ Dec 4 '16 at 2:49
  • @esQmo It's Verizon, of course it's locked – Tyler Richardson Dec 4 '16 at 3:17
  • I think the update you download had a patch that closed the security holes used by one-click rooting apps. – esQmo_ Dec 4 '16 at 3:38
0

You need to do a couple of things to get your phone rooted, not temp root.

There is a step-by-step guide on Instructable. Just follow it.

If the above doesn't work, try this one.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.