0

I have lenovo vibe shot and I have updated it with Android 6.0.1, rooted it with SuperSU 2.78 and installed systemless xposed framework on it all of the things are going well but

recently I tried to change the boot animation and I realized that I dont and I cant have writing access to /system and any of its sub folders (i want to replace a couple of MP4 files inside /system/media

no matter if I use mount commands from adb from PC or any other app in my mobile, write access will not be given for example ES File explorer says it is read only, when I click on write and click OK, it will show no error, but going to same setting again it shows read only selected again

similar is the case with Root Browser

I think it is due to systemless root

But is there any way I can get write acccess to /system/media ??? plz help

  • 1
    Not sure, but I rather suspect SELinux & friends here, running in enforced mode and prevent even root from "doing things". Just a hint to look for; I've not played with that myself, so I cannot give details. – Izzy Dec 5 '16 at 7:14
  • Yeah, disable SELinux by su -c setenforce 0 and then try to remount it as rw as Izzy said. Might be the issue – Gokul NC Dec 5 '16 at 7:21
  • still no luck I have tried with Insecure ADBD apk as well, still all I get is a read-only error Some where I read X-plorer can do it, I tried and it did overwritten files there but after some seconds device rstarted showing Android is updating, then some thing wrong happened with USB debugging, although it is allowed in the device, still computer is not recognizing it and on each restart it shows android updating – Usman Waheed Dec 5 '16 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.