0

Im running Lollipop 5.1.1, never had this problem before. My devices always need root access so it is rooted, and I like to customize so it is a custom ROM, but neither of those things should matter in this situation: Yesterday I made the stupid mistake of uninstalling Google PDF Viewer while, after having installed it as a system app, and while other GAPPS were running. As you can imagine this repeatedly crashed the GAPPS packages and I had to hardboot. It bootlooped. Im using one of the most locked down android phones to be released (the infamous SGH-I337) and have managed to do everything from properly AOSP-ifying TW ROMS to directly flash custom kernels and bootloaders in the past (thankfully I've managed to keep a particular older more open kernel seeing as I do all flashes directly through a PC/FlashFire/TWRP).

Now this probably seems like Im droning on, but its related. In line with the above one of the things I did a while back after getting tired of tediously dropping to stock 4.4, re-rooting, installing TWRP, etc. any time I made a mistake when modifying the system was set up an emergency recovery system for my phone. If I bootloop I can hook my phone to Odin or Heimdall, flash an older kernel I have, insert an recovery disk (microSD) and use a copy of TWRP thats on it to wipe my Dalvik/System/Cache and reinstall my ROM/previous kernel without loosing anything aside from the Xposed framework. This is the method I used yesterday to recover, and it worked great, phone was working again in 40 minutes (compared to the usual 12 hours) and all of my data was retained. I made my /System customizations again and everything felt identical, except for one thing that I noticed while testing ringtones: now there is a 50 second delay on any and all audio I attempt to play from my file manager, and for no apparent reason.

The strangest thing? It isnt a glitch or corrupted system component, because its accompanied by a timer consisting of toast messages. Yes, Toasts, counting down from 50 to 1 every time I try to open any audio, and only from the file manager. The issue doesnt happen in Play Music (my only audio app, and the one that plays the audio when I'm in the file manager) and it also doesnt happen when I use the "Open With" option (which opens it immediately in the PM overlay). I use Amaze File Manager, and I have been for a long time, this has never been an issue before, and it isnt a feature. Its quite agrivating and any ideas are appriciated. Thanks.

  • This happens with any file manager ? Did you try ES Explorer yet? – esQmo_ Dec 7 '16 at 0:17
  • @esQmo I don't much like ES Explorer so I don't have it installed but I have tried it with FX File Explorer and the problem didn't occur, the files started playing immediately. (It should be noted that FX has it's own media player so it doesn't open in the GPM overlay when opened in FX, which might be why its instant.) – Alison E.E. Dec 8 '16 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.