0

I was trying to get TWRP on my Asus Zenfone 2 ZE551ML (Stock firmware, WW-2.20.40.198). In order to do that, I tried to unlock the bootloader using this guide. I don't believe the unlocking really worked, though, because every time I tried to flash TWRP through Fastboot or the app, it failed.

It did, however, lose me my stock recovery. If I go to the bootloader and select "RECOVERY MODE", the phone just restarts and goes to the same bootloader again. So I got neither the stock recovery, nor TWRP.

As you can see from this answer, the only way I know how to flash stock firmware is through the stock recovery.

I did manage to root and install Xposed, though, both through adb. What worries me, though, is that if some root app or Xposed module mess up my phone somehow, I won't be able to flash stock firmware or a backup. So I really need a recovery. I would actually prefer to have the stock recovery at this point.

What can I do? I need the stock recovery to flash the stock firmware, but I can't.

I've tried Asus Flashtool before, but it didn't work. I think maybe it's because I tried it on Windows 10, some users said it worked better with Windows 7.

How can I get my recovery back?

1

You can flash the stock recovery through fastboot. The complete guide for flashing is here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.